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Overview
A VERICUT software installation is typical of any other software installation on your
computer. You simply follow the onscreen instructions for the software components
you wish to install and where you want them installed on your PC. The software can be
installed on as many PC’s as you like. The number of licenses available determine how
many of the copies can be run simultaneously. VERICUT and its features are managed
through the license manager. This document applies to VERICUT Verification and
VERICUT Drilling and Fastening (VDAF)

Considerations before Installation
VERICUT installation is very simple but you need to know a few things prior to installing
your software. Some of the menu options you’ll see during the installation require you
to know what VERICUT products you purchased so you know what to select during the
installation process. If you are planning on installing the license server please note that
you must have administrator privileges to perform the license server configuration. You
must also have administrator privileges to install the Microsoft redistributable run-time
libraries if necessary. It’s also possible that the windows security settings on your PC will
require administrative privileges to install the base software also. Check with your IT
administrator about your security settings prior to attempting installation.
Take a look at the pc requirements and the licenser server configuration before
installing the software. (click on the links below)
PC requirements
License Server
Terminology
Client Computer — The computer that runs the VERICUT software.
License Server Computer — The computer running the license server program. It
may also run the VERICUT client software concurrently
License Server Program — The program providing licenses for VERICUT. VERICUT
requires a license, so the License Server Program must be running for VERICUT to
operate. VERICUT uses the Sentinel RMS license server program from SafeNet. The
license server program and VERICUT communicate using TCP/IP network protocol.
Only one Sentinel RMS license server program may run on a computer.
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Installation from a DVD
Insert the DVD into the Drive and follow the onscreen instructions.

Installing from A downloaded Zip file
You can request a download of the VERICUT installation files from the CGTech website.
http://www.cgtech.com/vericut_support/request-software-update
Once you downloaded the zip file you’ll need to unzip it to a temporary folder. While
unzipping the file you’ll be prompted for a password. This password will be in the email
that was sent to you for the download link.
From the temporary folder where you unzipped your installation, double click (or right
click, open) on the setup.exe. Next, follow the on-screen instructions
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Basic VERICUT Product Installation
Insert the DVD or run the setup.exe from the folder containing the downloaded
installer.

Select the desired
language from the
dropdown list at
the bottom and
click on the OK
button.

The Introduction
page will be
displayed. Click the
“Next” button to
continue.
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The license
agreement page will
then be displayed.
Read the license
agreement.
If you agree, select
the “I accept the
terms and
conditions”
Click the “Next”
button to continue.

The folder location
will then be
displayed.
Accept the default
location or browse
for a different
location.
When you’re
satisfied with the
location, click the
“Next” button to
continue

5

Installing CGTech Products

Choose your
installation options.

Full installs the product, license server, help, samples and training files. This is the
recommended setting.
Partial installs the product, license server and help files.
Custom allows you individually to choose which items get installed.
If you’ve chosen
the Custom option
the next screen will
allow you to select
which components
of the product to
install. Make your
selections and click
the “Next” button
to continue.
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Choose which
license server to
access.
•

Use Existing
License server
on Remote
Computer.

•

The Use Existing
License server
on this

•

Install a license
server on this
computer.
(NOTE:
installing new
license server
requires
administrative
privileges)

Click the “Next”
button to continue.
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Shortcut
Locations
Choose where
you want you
shorts to be
located. On the
Desktop, in your
Quick Launch
bar or in a
program group
in your start
menu. You may
select as many
of these option
as you want.
NOTE: It is
recommended
that you always
keep the
program group
as a selection.
The group in
the start menu
will contain
several utilities
that
you may wish
to access later
on.
Click the “Next”
button to
continue
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VERICUT Product
Shortcuts
Select which
product(s) you which
to install and create
shortcuts for.
Make sure you know
which products you
purchased prior to
making your
selection.
Click the “Next”
button to continue.
Defaults Units
Choose the default
units to use when
opening VERICUT.
During normal
VERICUT operation,
the units can also be
selected when
starting a new
project.
Once a unit has been
selected it’s saved
with the project file.
Click the “Next”
button to continue.
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Select which Help
Documentation you
would prefer: Online
or Local.
Click the “Next”
button to continue

Select Additional
interfaces.
If you purchased
additional interfaces
in the list, select
them to have them
installed.
NOTE: there may be
more options
available than this
image depicts.
Click the “Next”
button to continue
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If you selected the
Esprit interface you
will be prompted for
the location of the
Esprit installation. If
it’s not the default
installation listed
then click on the
“Choose” button to
locate the Esprit
installation.

If you selected the
EdgeCam interface
you’ll be prompted to
select the installation
directory.

If you selected the
Mastercam interface
you’ll be prompted to
select the installation
directory.
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The Summary page
will then be
displayed.
Review your choices.
If you need to go
back and make any
changes click on the
“Previous” button to
return to the topic
that needs a
correction.
Clicking the “Install”
button will begin the
installation process.
The installation
progress screen will
be displayed during
the installation.

12

Installing CGTech Products

Once the installation
is completed a
window will be
displayed asking if
you would like to
view the postinstallation
instructions. This will
launch your browser
and provide a link to
take you to the
CGTech website to
the on-line postinstallation
instructions.
If you wish to install a
license server on this
PC then check the
box and click next.
Click the “Done”
button to exit the
Installer.

13

Installing CGTech Products

If you opted to install
the license server,
click next to
continue.

Click on the accept
button and then click
next to continue

Choose a new
location or click next
to accept the default
location to continue.
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Check the program
group option
(recommended) to
create a program
group in the start
menu.
This group contains
additional utilities for
configuring the
license server as
shown on the next
page.
This picture shows
the additional
utilities available
when available
using the program
group option.

The pre-installation
page is now
displayed. Examine
the install options
selected. If necessary,
click the previous
button to go back
and change any
options otherwise
click next to continue
the installation. Click
Done when the
installation is
completed.
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Basic License Server Configuration
NOTES FOR EXISTING USERS
As of the VERICUT 9.0 release, the license file manager from the VERICUT 9.0 installation
must be installed (Sentinel version 9.1). Prior versions of the Sentinel License Server are
not compatible with the new license file format.
In addition, those running the Sentinel License Server on a Virtual Machine must
specifically request a Virtual Machine Enabled license file from CGTech. Attempting to
run a VM disabled license from a Virtual Machine will result in error.
This set of instructions assumes that you have a standard Windows network
configuration with TCP/IP. You must have administrative privileges in order to install the
license server or the Microsoft redistributables.
Before you can install and configure the license manager service you must first obtain a
license file email from CGTech. If you’re a new user of VERICUT you can go to the
CGTech website to request your license file. Before going to the website to request your
license, you need to be prepared to provide your 6 digit company ID, your Host Name
(name of the server or PC running the license manager) and the Host ID (the 12 digit
MAC address of the server or PC running the license manager).
If you don’t know your 6 digit company ID you can contact you CGTech Sales engineer or
the technical support department
You can locate your host name by opening control panel and selecting System. The host
name is the Computer name.

You can determine your Host ID by running the HOST
ID utility from the start menu. This will display a
command window with 1 or more 12 digit Ethernet
addresses. Choose an address from the list.
Example:
Ethernet 1: 0001CF45A789
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Ethernet 2: 2001BC23B123
Once you have this information you can go to the CGTech website and complete the
license request form. The form will be sent to the email address you specified on the
form.
http://www.cgtech.com/vericut_support/request-license
Once you have your license file email available, proceed with the following steps.
Go to the start menu and select the VERICUT license folder
that was created during the installation process
Next, select the license server only folder and then select
Configure License and Setup Server. This utility performs
the following tasks.

1. Creates a license file from your license email
2. Sets the LSERVOPS environment variable to point to
your new license file location.
3. Stops the existing server if one exists
4. Removes the existing license server service.
5. Installs the new license server service.
6. Updates the new license server service with the new license file features.
If you get any errors during this process please go to the trouble shooting section.
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If no errors are generated then run the Sentinel LM License
Administrator (wlmadmin.exe) from the start menu,
VERICUT Installation, License Administration.

When the license administrator launches, expand out the subnet servers (+) and then
expand out the computer name. You should see all you license features appear.
Selecting the license feature in the list will display the name of the feature and how
many license of the feature you have available.

At this point the client PC’s should be able to run VERICUT. If VERICUT fails to launch,
take note of the error message and go to the trouble shooting section of this guide.
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Choose an Installation Configuration
There are several different ways to configure your VERICUT software installation. The
following are common configurations: a simple single computer or stand-alone
installation and multiple-computer installations.

Both the License Server and the VERICUT software run on the same computer

License server running on a different PC on the network
(NOTE: The license server computer may also run the VERICUT application)
(Back to Things to Consider Before Installation)
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VERICUT System Requirements
Version 9.0
When considering system requirements you need to consider all the tasks it will be
performing. For the purposes of discussion, we’ll only reference 64 bit CPU’s and
operating systems. VERICUT Version 9.0 supports only 64 bit CPU’s and operating
systems. As of today, some CAD/CAM companies have dropped support for 32 bit
applications and only deliver 64 bit versions.
Considerations:
1) What is the physical size of the part you will simulate?
2) What other software applications are running while VERICUT is running?
3) What requirements do the other applications have (both memory and graphics)?
VERICUT performance is primarily affected by the simulation tolerances used and the
speed of the CPU’s. The faster the CPU speed, the faster your programs will run. The
length of part programs being simulated does not affect VERICUT speed. Typical CPU
clock speed for a system running engineering applications ranges from 2.8 to 3.5, or
higher. In addition, the number of CPU’s (cores) can boost performance, especially when
running multiple applications concurrently.
The link below takes you to the Intel site where you can review the current CPU’s
available and read up on some of the latest CPU technology.
http://www.intel.com/content/www/us/en/processor-comparison/compare-intelprocessors.html?select=desktop
The amount of physical memory in your computer will impact the number of
applications you can run at the same time without having physical memory limitations
affect performance. When running VERICUT, the physical size of your part, tolerance,
program size and features used also impacts the amount of memory required for the
simulation. For most VERICUT simulations, 8 GB of physical memory is sufficient for
VERICUT, along with a few other smaller applications running concurrently. When the
part sizes are substantially larger (400” x 100” x 100” or more), or tolerance
requirements are very high, you may need to increase memory to 12 or 16 GB.

IMPORTANT! Always check the latest system requirements, available at VERICUT
System Requirements webpage.
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NOTE: Requirements have changed – review carefully

Minimum Requirements (for running VERICUT only)
•

Two or three button mouse
(Three button mouse with mouse-wheel is recommended due to new dynamic
view controls)

•

Network interface card

•

Graphics device capable of displaying at least 16K colors

•

OpenGL compatible graphics accelerators can be used in a machine simulation
view and for dynamic rotate/pan/zoom in a workpiece view. Due to the large
amount of graphics memory required to display the cut stock, graphics memory
of 512MB minimum is recommended, and 1GB or more is preferred.

Windows 64 bit Requirements
Disk Space

1 GB (full installation including Library, Samples, and Help
files, and Java Run-Time)
2 GB required if also installing the Model Interfaces Feature

Temporary Disk Space

4 GB required during installation, in addition to the
permanent Disk Space above.

Page File

2-times available physical memory recommended
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Windows VERICUT 9.0 works on Windows 7 or 10, 64 bit.
Operating
VERICUT 9.0 is not supported on Windows 2000, Windows 98, Windows ME and
System
Windows NT operating systems. Click here for more information.
Java Run Time Environment 1.7.0_80 (included in the VERICUT

installation)
Windows Script 5.3 or later is required for the CATIA V5 Interface
TCP/IP Network Protocol installed on the network device
VERICUT on Windows 7 64 may require installation of Windows C++ run-time libraries
(Microsoft Redistributables). An administrative user must do the installation. The runtime library installer is included on the VERICUT DVD and in the downloadable zip file of
the VERICUT installation. The installer file name is vcredist_x64.exe. Double-click on the
file to run the installer.
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The Microsoft Redistributable Installer is also available for download at:
http://www.cgtech.com/vericut_support/system-requirements
VERICUT 9.0 uses different run-time libraries than earlier versions.
The different versions of run-time libraries can be installed together on the same
computer if you need to run earlier versions concurrently.
Physical
Memory

Windows 7 and XP 64 bit - 4 GB is required, 8 is recommended.

Processor Intel or 100% Pentium-compatible Processor.
2.5 GHz or faster is recommended.
Multiple processors improve performance, especially when running other large
programs concurrently with VERICUT.
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Basic Troubleshooting
Errors Running Vericut
“Error No License Server Found”
Cause - The license server is not running.
Solution – Start the license server utility. Make sure the license server is installed
NOTE: loading or stopping/starting the license server requires administrative privileges.
Cause - The server name is incorrect
Solution – From the start menu, CGTech program group, license administration, run the
“Specify License Server Computer” utility. This will allow you to edit the LSHOST variable
with the correct server name or IP address.
“License server found but invalid version number”
Cause – Typically this is caused by an older license file being
Solution – Ensure that the license file being used is for 9.0.
Check the lservops environment variable to be sure that it points to the correct location
for the 9.0 license file. Either edit the LSERVOPS variable or move the license file to the
correct location.
NOTE: editing the LSERVOPS variable requires administrative privileges.
“Unable To Access Shared Library”
Cause – Missing the Microsoft redistributables.
Solution – run the vcredist_* executables from the redist folder of your VERICUT
installation or from the redistributables folder of your VERICUT Installation DVD or
folder.
NOTE: running these files requires administrative privileges.
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“Error Loading ACIS Libraries”
Cause - Model interfaces not installed
Solution – Run the Model Interfaces Executable from the DVD or the installation folder.
(model_interfaces_v73.exe)
Cause - Missing the Microsoft redistributables.
Solution – run the vcredist_* executables from the redist folder of your VERICUT
installation or from the redistributables folder of your VERICUT Installation DVD or
folder.
NOTE: running these files requires administrative privileges.
“License server found but features not present”
Cause – Firewall or anti-virus is blocking communication between the license server and
the client running VERICUT.
Solution – Open up the firewall / anti-virus utility and add exceptions for port 5093 as
well as lservnt.exe.

Errors Installing the Sentinel License Server
“Cannot Communicate with License server”
Cause - Missing the Microsoft redistributables.
Solution – run the vcredist_* executables from the redist folder of your VERICUT
installation or from the redistributables folder of your VERICUT Installation DVD or
folder.
NOTE: running these files requires administrative privileges.
“Sentinel RMS Development Kit: Error[150] The specified lock code is invalid
Cause – MAC address in license file does not match MAC address on the server
Solution – Move the license server to the correct computer or request a new license file
with the correct MAC address. To request a new license file you must fill out a license
transfer request online at:
http://www.cgtech.com/vericut_support/request-license/transfer-request/
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Error license file cgtech.lf does not exist
Cause – The update batch file cannot locate the cgtech.lf license file.
Solution – Make sure the cgtech.lf was created in the license folder of your VERICUT
installation. Ensure that you have write permissions for this folder.
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Other Installation Types
Install VERICUT License Server Only
It may be desirable to install only the license server program on the license server
computer. To do this, run the “license_server_install.exe” from the DVD or download
folder.
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Using Silent Install
Silent Mode
Silent mode enables an installer to run without any user interaction on Windows
platforms. If you choose to run this option, there will be no console or GUI output
during installation. Silent mode supports the setting of a target directory, shortcuts
directory, and Components/Features via either command-line arguments or a
properties file. Silent mode is supported in both the installer and uninstaller runtime
environments. InstallAnywhere and end-user-defined variables may be set through
command-line parameters and/or a properties file.
An installer properties file or a command-line parameter may trigger silent mode.
Installer Properties File
An installer properties file is an ASCII text file that defines certain parameters for your
installation. This may be useful if you have a complex project that you are installing both
internally and externally. Your internal end-users do not need to see panels such as the
License Agreement panel. The properties file is an ideal way to turn panels on or off
depending on your specific needs. In addition, the properties file can define the type of
installation you want to run, such as console or silent.
NOTE: Please make sure that your properties file ends in .properties, not .txt.

Tip: If the install.properties file is in the same directory as your installer, it will be

invoked automatically. However, if it is in a different directory or a different name, you
may use the following command line option to direct it to the relative path:
C:\\ <path to the installer> -f <path to the properties file>
Command Line Parameter
To call the properties file from the command line, type the following command:
install.exe -f <properties file>
You may use the direct or the relative path to the properties file.
InstallAnywhere variables may be incorporated in these values, and they will be
resolved at install time.
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NOTES:
1. File separators should be denoted by the “\\”.
2. Values may ignore case.
3. Silent mode will override action panel values.
4. In any mode on Windows systems, installers and uninstallers will always display
the very last "Cleaning-up" dialog box, as well as the "Preparing to install" panel.
VERICUT Properties File Variables
An example of an install.properties file with all parameters is as follows
#INSTALLER GUI? Silent, Console, GUI
#--------------------INSTALLER_UI=Silent
#Choose Install Folder
#--------------------USER_INSTALL_DIR=C:\\Program Files\\CGTech\\VERICUT 9.0
#Choose Type of Installation
#--------------------------CHOSEN_FEATURE_LIST=VERICUT,Help,Samples
CHOSEN_INSTALL_FEATURE_LIST=VERICUT,Help,Samples
CHOSEN_INSTALL_SET=Full
#License Server Location
#----------------------LICENSE_SERVER_EXISTS_REMOTE=1
LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=LicenseServer
LICENSE_SERVER_EXISTS_LOCAL=0
LICENSE_SERVER_INSTALL_LOCAL=0
#VERICUT Shortcut Locations
#-------------------------USER_INPUT_DESKTOP_FLAG=1
USER_INPUT_QUICK_LAUNCH_FLAG=1
USER_INPUT_PROGRAM_GROUP_FLAG=1
USER_INPUT_PROGRAM_GROUP_NAME=CGTech VERICUT 9.0
USER_INPUT_ALL_USERS_FLAG=0
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#VERICUT Product Shortcut
#-----------------------# "1) VERICUT"
DEFAULT_BASE_LIC_VAR_1=1
# "2) VERICUT Single Platform"
DEFAULT_BASE_LIC_VAR_2=1
# "3) Reviewer"
DEFAULT_BASE_LIC_VAR_3=1
# "4) VERICUT Drilling and Fastening (VDAF)"
DEFAULT_BASE_LIC_VAR_4=1
# "5) ToolMan"
DEFAULT_BASE_LIC_VAR_5=1
#VERICUT Default Units
#--------------------DEFAULT_UNITS_VAR=\"1) Inch\",\"\"
DEFAULT_UNITS_VAR_1=1) Inch
DEFAULT_UNITS_VAR_2=
#VERICUT Interfaces
#-----------------#Install Complete
#---------------The above sample will install an Inch version of VERICUT and create shortcuts for
VERICUT, SP, Reviewer and ToolMan.
Below is a list of possible variable:
#INSTALLER GUI? Silent, Console, GUI
#--------------------INSTALLER_UI=Silent
#Choose Install Folder
#--------------------USER_INSTALL_DIR=C:\\Program Files\\CGTech\\VERICUT 9.0
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#Choose Type of Installation
#--------------------------CHOSEN_FEATURE_LIST=VERICUT,Help,Samples
CHOSEN_INSTALL_FEATURE_LIST=VERICUT,Help,Samples
CHOSEN_INSTALL_SET=Full
#License Server Location
#----------------------LICENSE_SERVER_EXISTS_REMOTE=1
LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=LicenseServer
LICENSE_SERVER_EXISTS_LOCAL=0
LICENSE_SERVER_INSTALL_LOCAL=0
#VERICUT Shortcut Locations
#-------------------------USER_INPUT_DESKTOP_FLAG=1
USER_INPUT_QUICK_LAUNCH_FLAG=1
USER_INPUT_PROGRAM_GROUP_FLAG=1
USER_INPUT_PROGRAM_GROUP_NAME=CGTech VERICUT 9.0
USER_INPUT_ALL_USERS_FLAG=0
#VERICUT Product Shortcut
#-----------------------# "1) VERICUT"
DEFAULT_BASE_LIC_VAR_1=1
# "2) VERICUT Single Platform"
DEFAULT_BASE_LIC_VAR_2=1
# "3) Reviewer"
DEFAULT_BASE_LIC_VAR_3=1
# "4) VERICUT Drilling and Fastening (VDAF)"
DEFAULT_BASE_LIC_VAR_4=1
# "5) ToolMan"
DEFAULT_BASE_LIC_VAR_5=1
#VERICUT Default Units
#--------------------DEFAULT_UNITS_VAR=\"1) Inch\",\"\"
DEFAULT_UNITS_VAR_1=1) Inch
DEFAULT_UNITS_VAR_2=
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#VERICUT Interfaces
#-----------------SPATIAL_INSTALL=1
ESPRIT_INTERFACE_INSTALL=1
EDGECAM_INTERFACE_INSTALL=1
EDGECAM_2017_R2_SU3_SELECTED=1
EDGECAM_2017_R2_SU1_SELECTED=1
EDGECAM_2017_R1_SELECTED=1
EDGECAM_2016_R2_SELECTED=1
EDGECAM_2016_R1_SU1_SELECTED=1
EDGECAM_2015_R2_SELECTED=1
EDGECAM_2015_R1_SELECTED=1
EDGECAM_2014_R2_SU2_SELECTED=1
EDGECAM_2014_R1_SELECTED=1
EDGECAM_2013_R2_SELECTED=1
EDGECAM_2013_R1_SELECTED=1
MASTERCAM_INTERFACE_INSTALL=1
MASTERCAM_2018_SELECTED=1
MASTERCAM_2017_SELECTED=1
MASTERCAM_X9_SELECTED=1
MASTERCAM_X8_SELECTED=1
MASTERCAM_X7_SELECTED=1
MASTERCAM_X6_SELECTED=1
#Choose Esprit Folder
#-------------------ESPRIT_INSTALL_DIR=C:\\Program Files\\D.P.Technology\\ESPRIT
#Choose Edgecam 2013 R1 Folder
#----------------------------EDGECAM_2013_R1_INSTALL_DIR= C:\\Program Files\\Planit\\Edgecam 2013 R1
#Choose Edgecam 2013 R2 Folder
#----------------------------EDGECAM_2013_R2_INSTALL_DIR= C:\\Program Files\\Planit\\Edgecam 2013 R2
#Choose Edgecam 2014 R1 Folder
#----------------------------EDGECAM_2014_R1_INSTALL_DIR= C:\\Program Files \\Planit\\Edgecam 2014
R1
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#Choose Edgecam 2014 R2 SU2 Folder
#--------------------------------EDGECAM_2014_R2_SU2_INSTALL_DIR= C:\\Program Files\\Planit\\Edgecam
2014 R2 SU2
#Choose Edgecam 2015 R1 Folder
#----------------------------EDGECAM_2015_R1_INSTALL_DIR= C:\\Program Files\\Planit\\Edgecam 2015 R1
#Choose Edgecam 2015 R2 Folder
#----------------------------EDGECAM_2015_R2_INSTALL_DIR=C:\\Program Files\\Vero Software\\Edgecam
2015 R2
#Choose Edgecam 2016 R1 SU1 Folder
#--------------------------------EDGECAM_2016_R1_SU1_INSTALL_DIR=C:\\Program Files\\Vero
Software\\Edgecam 2016 R1 SU1
#Choose Edgecam 2016 R2 Folder
#----------------------------EDGECAM_2016_R2_INSTALL_DIR=C:\\Program Files\\Vero Software\\Edgecam
2016 R2
#Choose Edgecam 2017 R1 Folder
#----------------------------EDGECAM_2017_R1_INSTALL_DIR=C:\\Program Files\\Vero Software\\Edgecam
2017 R1
#Choose Edgecam 2017 R2 SU1 Folder
#--------------------------------EDGECAM_2017_R2_SU1_INSTALL_DIR=C:\\Program Files\\Vero
Software\\Edgecam 2017 R2 SU1
#Choose Edgecam 2017 R2 SU3 Folder
#--------------------------------EDGECAM_2017_R2_SU3_INSTALL_DIR=C:\\Program Files\\Vero
Software\\Edgecam 2017 R2 SU3
#Choose Mastercam 2018 Folder
#---------------------------MASTERCAM_2018_PATH=C:\\Program Files\\Mcam\\mcam2018
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#Choose Mastercam 2017 Folder
#---------------------------MASTERCAM_2017_PATH=C:\\Program Files\\Mcam\\mcam2017
#Choose Mastercam X9 Folder
#-------------------------MASTERCAM_X9_PATH=C:\\Program Files\\Mcam\\mcamx9
#Choose Mastercam X8 Folder
#-------------------------MASTERCAM_X8_PATH=C:\\Program Files\\Mcam\\mcamx8
#Choose Mastercam X7 Folder
#-------------------------MASTERCAM_X7_PATH=C:\\Program Files\\Mcam\\mcamx7
#Choose Mastercam X6 Folder
#-------------------------MASTERCAM_X6_PATH=C:\\Program Files\\Mcam\\mcamx6
#Install Complete
#---------------USER_SHOW_INSTALL_NOTES=0
RUN_LICENSE_SERVER_INSTALL=0

VERICUT Command Descriptions
Specify Silent Install
INSTALLER_UI=Silent
Use to specify that Silent install is to be used.
Choose Installation Folder
USER_INSTALL_DIR=insert destination path here
Use to specify the path to the VERICUT installation folder.
Example:
USER_INSTALL_DIR=C:\\Program Files \\CGTech\\VERICUT 9.0
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Choose Type of Installation
CHOSEN_INSTALL_SET=option
Use to specify which features are to be installed. Select one of the following options.
Full – VERICUT Product, Help, Sample and Training files will be installed.
Partial – VERICUT Product and Help files will be installed.
If either of the above options (Full or Partial) is used, no other commands are
needed to specify the features to be installed.
Example:
CHOSEN_INSTALL_SET=Full
Custom – Use this feature to select a “custom” group of features to be installed. Use
the CHOSEN_INSTALL_FEATURE_LIST command, defined below, to specify the
features that are to be installed.
CHOSEN_INSTALL_FEATURE_LIST=feature list
Use to specify the “custom” list of features to be used for the
CHOSEN_INSTALL_SET=Custom command described above. Choose one or more of the
following:
VERICUT – The VERICUT Product will be installed.
Help Files – The Help files will be installed.
Sample and Training Files – The Sample and Training files will be installed.
Example:
The following commands will install the VERICUT Product and the Sample and
Training files.
CHOSEN_INSTALL_SET=Custom
CHOSEN_INSTALL_FEATURE_LIST=VERICUT, Sample and Training Files
License Server Location
You can only use one of the following options: LICENSE_SERVER_EXISTS_REMOTE,
LICENSE_SERVER_EXISTS_LOCAL, or LICENSE_SERVER_INSTALL_LOCAL.
LICENSE_SERVER_EXISTS_REMOTE=value
Use a value of 1 to use an existing license server on a remote computer. A value of 0
indicates that this option is not to be used. If the option is not specified, it defaults to 0.
Use the LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME command, described below, to
specify the host name of the remote license server computer.
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LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=host name
Used with the LICENSE_SERVER_EXISTS_REMOTE command described above. This
command is used to specify the license server computer’s host name.
Example:
LICENSE_SERVER_EXISTS_REMOTE=1
LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=LicenseServer
LICENSE_SERVER_EXISTS_LOCAL=value
Use a value of 1 to use an existing license server on this computer. A value of 0 indicates
that this option is not to be used. If the option is not specified, it defaults to 0.
LICENSE_SERVER_INSTALL_LOCAL=value
Use a value of 1 to install a License Server on this computer. A value of 0 indicates that
this option is not to be used. If the option is not specified, it defaults to 0.
The license server installation starts after the VERICUT installation finishes. Have your
license email for this computer and version available.
NOTE: The use of this option requires that you are an “Administrator” user.
VERICUT Shortcut Locations
USER_INPUT_DESKTOP_FLAG=value
The USER_INPUT_DESKTOP_FLAG variable is used for adding icons to the Desktop. A
value of 0 does not add any icons to the Desktop. A value of 1 adds icons to the Desktop.
If the option is not specified, it defaults to 0.
USER_INPUT_QUICK_LAUNCH_FLAG=value
The USER_INPUT_QUICK_LAUNCH_FLAG variable is used for adding icons to the Quick
Launch taskbar. A value of 0 does not add any icons to the Quick Launch taskbar. A value
of 1 adds icons to the Quick Launch taskbar. If the option is not specified, it defaults to
0.
USER_INPUT_PROGRAM_GROUP_FLAG=value
The USER_INPUT_PROGRAM_GROUP_FLAG variable is used for adding icons and menus
to the Programs Menu. A value of 0 does not add any icons or menus to the Programs
Menu. A value of 1 adds icons and menus to the Programs Menu. If the option is not
specified, it defaults to 0.
USER_INPUT_PROGRAM_GROUP_NAME=name of program group
The USER_INPUT_PROGRAM_GROUP_NAME variable indicates the name of the
Program Group that is to be added to the Start > All Programs menu. If the option is not
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specified, it defaults to "CGTech VERICUT x.x.x", where x.x.x is the current VERICUT
version number.
USER_INPUT_ALL_USERS_FLAG=value
The USER_INPUT_ALL_USERS_FLAG variable indicates if any icons added by the previous
three options are added for all users of the computer or only the current user. A value
of 0 adds icons for the current user only. A value of 1 adds icons for all users. If the
option is not specified, it defaults to 0.
NOTE: The use of this option requires that you are an “Administrator” user.
VERICUT Product Shortcut
Use to specify the VERICUT Product Shortcut(s) that you would like to be installed in the
Program Group (CGTech VERICUT 9.0) for the current user.
DEFAULT_BASE_LIC_VAR=string series
"1) VERICUT"
"2) VERICUT Single Platform"
"3) Reviewer"
"4) VERICUT Drilling and Fastening (VDAF)"
“5) ToolMan
Example: VERICUT only
DEFAULT_BASE_LIC_VAR =\”1) VERICUT\",\“,\”,\”,\”
VERICUT Default Units
DEFAULT_UNITS_VAR=string series
“1) Inch”
“2) Millimeter”
Example: Inch
DEFAULT_UNITS_VAR=\"1) Inch\",\"\"
VERICUT Interfaces
SPATIAL_INSTALL=value
Used to specify if the Spatial software used for the Model Interface option gets installed.
A value of 0 does not install the Spatial software. A value of 1 installs the Spatial
software. If the option is not specified, it defaults to 0.
ESPRIT_INTERFACE_INSTALL= value
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Used to specify whether, or not, the Esprit-to-VERICUT Interface gets installed. A value
of 0 does not install the Esprit-to-VERICUT Interface. A value of 1 installs the Esprit-toVERICUT Interface. If the option is not specified, it defaults to 0.
ESPRIT_INSTALL_DIR=path
Use to specify the path of an existing Esprit installation folder.
Typically C:\Program Files (x86)\D.P.Technology\ESPRIT
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Example:
The following pair of commands is required to install the Esprit-to-VERICUT Interface
ESPRIT_INTERFACE_INSTALL=1
ESPRIT_INSTALL_DIR= C:\Program Files (x86)\D.P.Technology\ESPRIT

EDGECAM_INTERFACE_INSTALL=value
Used to specify whether, or not, the Edgecam-to-VERICUT Interface gets installed. A
value of 0 does not install the Edgecam-to-VERICUT Interface. A value of 1 installs the
Edgecam-to-VERICUT Interface. If the option is not specified, it defaults to 0.
EDGECAM_2013_R1_SELECTED=value
Use to specify if the EDGECAM 2013 R1 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2013_R2_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2013 R1 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2013 R1
EDGECAM_2013_R2_SELECTED=value
Use to specify if the EDGECAM 2013 R2 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2013_R2_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2013 R2 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2013 R2
EDGECAM_2014_R1_SELECTED=value
Use to specify if the EDGECAM 2014 R1 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2014_R1_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2014 R1 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2014 R1
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EDGECAM_2014_R2_SU2_SELECTED=value
Use to specify if the EDGECAM 2014 R2 SU2 interface is to be installed. A value of 0 does
not install the interface. A value of 1 installs the interface. If the option is not specified,
it defaults to 0.
EDGECAM_2014_R2_SU2_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2014 R2 SU2 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2014 R2 SU2
EDGECAM_2015_R1_SELECTED=value
Use to specify if the EDGECAM 2015 R1 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2015_R1_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2015 R1 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2015 R1
EDGECAM_2015_R2_SELECTED=value
Use to specify if the EDGECAM 2015 R2 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2015_R2_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2015 R2 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2015 R2
EDGECAM_2016_R1_SU1_SELECTED= value (0 or 1)
Use to specify if the EDGECAM 2016 R1 SU1 interface is to be installed. A value of 0 does
not install the interface. A value of 1 installs the interface. If the option is not specified,
it defaults to 0.
EDGECAM_2016_R1_SU1_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2016 R1 SU1 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2016 R1 SU1
EDGECAM_2016_R2_SELECTED=value
Use to specify if the EDGECAM 2016 R2 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
EDGECAM_2016_R2_INSTALL_DIR=path
Use to specify the path of the EDGECAM 2016 R2 Installation.
Typically C:\\Program Files (x86)\\Planit\\Edgecam 2016 R2
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Example:
The following three commands are required to install the Edgecam-to-VERICUT
Interface. This example is for installing the Edgecam-to-VERICUT Interface for Edgecam
2016 R2 but is representative of the commands needed for all Edgecam versions.
EDGECAM_INTERFACE_INSTALL=1
EDGECAM_2016_R2_SELECTED=1
EDGECAM_2016_R2_INSTALL_DIR=C:\\Program Files (x86)\\Planit\\Edgecam 2016 R2
MASTERCAM_X6_SELECTED= value
Use to specify if the Mastercam_X6 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
MASTERCAM_X6_PATH =path
Use to specify the path of the Mastercam X6 Installation.
Typically C:\\mcamx6\
MASTERCAM_X7_SELECTED=value
Use to specify if the Mastercam_X7 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
MASTERCAM_X7_PATH =path
Use to specify the path of the Mastercam X7 Installation.
Typically C:\\mcamx7\
MASTERCAM_X8_SELECTED=value
Use to specify if the Mastercam_X8 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
MASTERCAM_X8_PATH =path
Use to specify the path of the Mastercam X8 Installation.
Typically C:\\mcamx8\
MASTERCAM_X9_SELECTED=value
Use to specify if the Mastercam_X9 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
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MASTERCAM_X9_PATH =path
Use to specify the path of the Mastercam X9 Installation.
Typically C:\\mcamx9\
MASTERCAM_2017_SELECTED=value
Use to specify if the Mastercam_2017 interface is to be installed. A value of 0 does not
install the interface. A value of 1 installs the interface. If the option is not specified, it
defaults to 0.
MASTERCAM_2017_PATH =path
Use to specify the path of the Mastercam 2017 Installation.
Typically C:\\mcam2017\
Example:
The following pair of commands is required to install the Mastercam-to-VERICUT
Interface. This example is for installing the Mastercam-to-VERICUT Interface for
Mastercam 2017 but is representative of the commands needed for all Mastercam
versions.
MASTERCAM_2017_SELECTED=1
MASTERCAM_2017_PATH = C:\\mcam2017\
Install Complete
USER_SHOW_INSTALL_NOTES=value
Use to specify whether or not to show the post-installation configuration instructions.
This feature displays instructions on how to setup a license server, configure CAD/CAM
Interfaces, install CAD Model Interfaces or other configuration tasks. A value of 0 does
not display the post-installation instructions. A value of 1 displays the post-installation
instructions. If the option is not specified, it defaults to 0.
RUN_LICENSE_SERVER_INSTALL=value
Use to specify whether or not to run the license server installer. A value of 0 does not
run the license server installer. A value of 1 runs the license server installer. If the option
is not specified, it defaults to 0.
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VERICUT Reviewer Command Descriptions
Specify Silent Install
INSTALLER_UI=Silent
Use to specify that Silent install is to be used.
Choose Installation Folder
USER_INSTALL_DIR=destination path
Use to specify the path to the VERICUT installation folder.
Example:
USER_INSTALL_DIR=C:\\Program Files \\CGTech\\VERICUT 9.0
Choose Reviewer Platform
Use to specify the VERICUT Reviewer Windows platform that you would like to be
installed.
VERICUT_PLATFORMS=string series
Choose one of the following options.
Windows 32-bit
Windows 64-bit
Examples:
VERICUT_PLATFORMS=\"Windows 32-bit\",\"\"
VERICUT_PLATFORMS=\"\",\"Windows 64-bit\"
VERICUT Reviewer Shortcut Locations
Use to specify where you would like to create VERICUT Reviewer 9.0 shortcut(s)
USER_INPUT_DESKTOP_FLAG=value
Use to put a VERICUT Reviewer icon on the Desktop. A value of 0 does not put a
VERICUT Reviewer icon on the Desktop. A value of 1 puts a VERICUT Reviewer icon on
the Desktop. If the option is not specified, it defaults to 0.
USER_INPUT_QUICK_LAUNCH_FLAG=value
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Use to put a VERICUT Reviewer icon in the Quick Launch Bar. A value of 0 does not put a
VERICUT Reviewer icon in the Quick Launch Bar. A value of 1 puts a VERICUT Reviewer
icon in the Quick Launch Bar. If the option is not specified, it defaults to 0.
USER_INPUT_PROGRAM_GROUP_FLAG=value
Use to put a VERICUT Reviewer shortcut in a Program Group. A value of 0 does not put a
VERICUT Reviewer shortcut in a Program Group. A value of 1 puts a VERICUT Reviewer
shortcut in a Program Group. If the option is not specified, it defaults to 0. This
command is used with the USER_INPUT_PROGRAM_GROUP_NAME command described
below.
USER_INPUT_PROGRAM_GROUP_NAME=program group name
Use to specify the name of the Program Group that you want a VERICUT Reviewer
shortcut put in. This command is used with the USER_INPUT_PROGRAM_GROUP_FLAG
command described above.
USER_INPUT_ALL_USERS_FLAG=value
Use to specify that specified icons/shortcuts are to be added for all users of this
computer.
Examples:
The following command puts a VERICUT Reviewer icon the desktop.
USER_INPUT_DESKTOP_FLAG=1
The following pair of commands puts a VERICUT Reviewer shortcut in “CGTech VERICUT
Reviewer 9.0” program group.
USER_INPUT_PROGRAM_GROUP_FLAG=1
USER_INPUT_PROGRAM_GROUP_NAME = CGTech VERICUT Reviewer 9.0
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Stand-alone Tool Manager Command Descriptions
Specify Silent Install
INSTALLER_UI=Silent
Use to specify that Silent install is to be used.
Choose Installation Folder
USER_INSTALL_DIR= destination path
Use to specify the path to the Stand-alone Tool Manager installation folder.
Example:
USER_INSTALL_DIR=C:\\Program Files \\CGTech\\ToolMan 9.0
License Server Location
You can only use one of the following options: LICENSE_SERVER_EXISTS_REMOTE or
LICENSE_SERVER_EXISTS_LOCAL.
LICENSE_SERVER_EXISTS_REMOTE=value
Use a value of 1 to use an existing license server on a remote computer. A value of 0
indicates that this option is not to be used. If the option is not specified, it defaults to 0.
Use the LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME command, described below, to
specify the host name of the remote license server computer.
LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=host name
Used with the LICENSE_SERVER_EXISTS_REMOTE command described above. This
command is used to specify the remote license server computer’s host name.
Example:
LICENSE_SERVER_EXISTS_REMOTE=1
LICENSE_SERVER_EXISTS_REMOTE_HOSTNAME=LicenseServer
LICENSE_SERVER_EXISTS_LOCAL=value
Use a value of 1 to use an existing license server on this computer. A value of 0 indicates
that this option is not to be used. If the option is not specified, it defaults to 0.
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ToolMan Shortcut Locations
Use to specify where you would like to create ToolMan icons/shortcuts
USER_INPUT_DESKTOP_FLAG=value
Use to put a ToolMan icon on the Desktop. A value of 0 does not put a ToolMan icon on
the Desktop. A value of 1 puts a ToolMan icon on the Desktop. If the option is not
specified, it defaults to 0.
USER_INPUT_QUICK_LAUNCH_FLAG=value
Use to put a ToolMan icon in the Quick Launch Bar. A value of 0 does not put a ToolMan
icon in the Quick Launch Bar. A value of 1 puts a ToolMan icon in the Quick Launch Bar.
If the option is not specified, it defaults to 0.
USER_INPUT_PROGRAM_GROUP_FLAG=value
Use to put a ToolMan shortcut in a Program Group. A value of 0 does not put a ToolMan
shortcut in a Program Group. A value of 1 puts a ToolMan shortcut in a Program Group.
If the option is not specified, it defaults to 0. This command is used with the
USER_INPUT_PROGRAM_GROUP_NAME command described below.
USER_INPUT_PROGRAM_GROUP_NAME=program group name
Use to specify the name of the Program Group that you want a VERICUT Reviewer
shortcut put in. This command is used with the USER_INPUT_PROGRAM_GROUP_FLAG
command described above.
USER_INPUT_ALL_USERS_FLAG=value
Use to specify that specified icons/shortcuts are to be added for all users of this
computer.
Examples:
The following command puts a VERICUT Reviewer icon the desktop.
USER_INPUT_DESKTOP_FLAG=1
The following pair of commands puts a VERICUT Reviewer shortcut in “CGTech VERICUT
Reviewer 9.0” program group.
USER_INPUT_PROGRAM_GROUP_FLAG=1
USER_INPUT_PROGRAM_GROUP_NAME = CGTech ToolMan 9.0
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VERICUT Interfaces
SPATIAL_INSTALL=value
Used to specify if the Spatial software used for the Model Interface option gets installed.
A value of 0 does not install the Spatial software. A value of 1 installs the Spatial
software. If the option is not specified, it defaults to 0.
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Redundant License Server Setup
If you plan to configure redundant license servers you should have identified the three
(3) required license server computers, provided their Host ID's to CGTech, and received
a license email containing the special license keys for redundant license servers. You
should also have specified the three license servers (in the order,
leader:follower1:follower2) during the VERICUT installation.
A redundant license server configuration requires a special license configured for three
(3) license servers. Earlier installation instructions explained how to request the license.
Redundant license server configuration should only be done by experienced system
administrators with networking experience.
NOTE: Each redundant server must have a static IP address. Dynamic IP addresses cause
poor performance or failure.
Follow the steps below to setup a Windows redundant license server configuration.
These steps must be done by an "Administrator" user. The steps assume you have
received the license email from CGTech.
1. Save License File from License Email.
(requires privileges to write to the VERICUT installation folders)
Select Start > All Programs > CGTech license Server > License Server Only > Save
License File from License Email.
When the Create VERICUT License File screen displays, drag and drop the
VERICUT license email from Microsoft Outlook, or Outlook Express, into the
Create VERICUT License File screen. If you use another email program or
cannot access the license email from the license server computer, save the
license email as a "Text Only" or plain text file, then drag and drop the saved
file into the Create VERICUT License File screen. You can also Copy/Paste the
email contents into the Create VERICUT License File screen.
The Create VERICUT License File screen's text area displays all the added license
keys, followed by the message:
"License file C:\cgtech60x\windows\license\cgtech.lf created successfully".
Close the Create VERICUT License File screen after the license file has been
created.
2. Determine the IP address of each of the 3 license servers.
These will be used in the redundant license file configuration in the following steps.
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3. Use WRlfTool.exe (eg. C:\Program Files\CGTech\License Server folder of your
VERICUT installation) to create the redundant license file.
Run …\windows\license\WrlfTool.exe.
In the WRlfTool panel select File -> New.
Press the Add Server button (in the upper half of the window).
In Add Server to Pool panel, enter the Hostname and IP Address (or IPX Address)
for the "leader" license server computer, and then press OK.
Press the Add Server button two more times to add the Host Names and IP
addresses for each of the two "follower" license server computers. All three
redundant server host names and IP addresses should now appear in the
Redundant Servers list.
Press the Add License button (in the lower half of the window).
In the Add Redundant License panel, select "Read License(s) from file".
Press Browse and navigate to, and select, the cgtech.lf file you saved in step 1C
above. Press Open, and then press OK.
The Edit License panel opens, showing the first VERICUT license key in the
License Code field on the right side of the panel, and the number of available
licenses displayed in the Number of Tokens field (lower left in the panel).
On the right side of the panel the 3 license server host names appear in the
Server column. Check the Include checkboxes for all 3.
Enter the value from Number of Tokens (lower left) in the Num Tokens column
to the right of the first or "leader" server. This assigns all tokens for the
displayed license key to the leader license server. Make sure that the Num
Tokens values, for the two "follower" servers, is set to zero.
Select Next License >> at the bottom of the panel to display the information for
the next VERICUT feature. Repeat the previous step to assign all tokens for
this license key to the leader license server.
Repeat for each license key.
Press Done at the bottom of the panel after the last license key is completed.
Select File->Save As and save the redundant license file as "cgtech.lf" in the
…/windows/license folder of the leader license server's VERICUT installation.
4. Copy the redundant license to the other license servers.
Copy the file cgtech.lf into the …/windows/license folder of the VERICUT installation on
each of the other two license server computers.
5. Start the License Servers.
CGTech strongly recommends you configure the license server program to
automatically start when you start your computer.
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NOTES:
1. The license server computer requires TCP/IP network protocol installed on the
network adaptor. See the section, Check Windows Network Configuration for
more information.
2. The following steps must be done by an Administrator user.
3. If you are installing on a computer running Windows 7 Pro you will need to do
the following before continuing with the Configure License & Setup Server steps.
•
•

Go to Control Panel > User Accounts > Change User Account Control
settings (aka UAC).
Change it from Default to Never notify
The Never Notify setting is to be used when using a program not certified for
Windows 7 because it does not support User Account Control (like Sentinel
or VERICUT).

6. On the "leader" license server computer:
Select Start > All Programs > CGTech License Server > License Server Only > Start
License Server Service. This will automatically remove any existing service and add
and start the service from the current folder.
A. Select Start > All Programs > CGTech License Server > License Server Only > Set
License File Environment Variable.
B. Modify the system environment variable LSERVOPTS created in the previous
step.
C. The following is one way to do it:
a. Find the "My Computer" icon, right-mouse click on it, and select
Properties.
b. In the System Properties panel, select the Advanced tab. Press the
Environment Variables button located near the bottom of the panel.
c. In the Environment Variables panel, scroll the lower System Variables
list, select LSERVOPTS, and press the Edit button.
d. In the Edit System Variable panel change the Variable Value by replacing
the "-s" with "-rlf"
e. Press OK in the Edit System Variable panel, and all remaining panels.
D. Restart the computer.
E. Repeats steps A through D for the two follower computers.
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NOTES:
1. Be sure to start the 3 redundant license server computers in the same order
specified when the redundant license file was created. Starting them out-oforder could cause problems designating the “leader” computer and assigning
tokens. You should wait 1 or 2 minutes between starting each license server
computer to make sure that it is fully started and ready to communicate with
the next one. There is no "maximum" time limit between starting the license
server computers.
2. When starting a redundant license server, the error message "lservrc not
found" may display. This message can be ignored.
7. Verify the license servers started.
All 3 redundant license servers should now be running and should be configured
to automatically start. You can confirm that the server program is running using
the Sentinel License Administrator program.
Select Start > All Programs > CGTech License Server > License Utilities> Sentinel
License Administrator (WlmAdmin). You should see all 3 license server
computers' host names appear under the Defined Servers list under the 'tree'
displayed on the left side of the window.
If they do not display you may need to add them using Edit > Defined Server List
in the WlmAdmin panel. In a few seconds your VERICUT licenses should appear
under the server computer's name (you may have to expand it).
The redundant license server computers are now configured to automatically
start the license server program, the VERICUT license keys exist in
…\windows\license\cgtech.lf, and the license server programs are configured to
read VERICUT license keys from the file.

NOTE: During VERICUT installation you should have specified the 3 license

servers when prompted for the license server name. If you did not enter the
three license server host names during installation, you can modify the name by
selecting Start > All Programs > CGTech VERICUT x.x > License Administration >
Specify License Server Computer. When the Notepad editor opens, change the
line "set LSHOST=..." to be:
set LSHOST=hostname1:hostname2:hostname3
Where "hostname1", etc. are the names of your 3 redundant license servers. The
names MUST be specified in the same order used when the redundant license
file was created. The three hostnames are separated by colons ( : ).
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8. Save the file and exit Notepad.
NOTE: For more detailed information about setting up a redundant license server
configuration, see the Sentinel RMS License Manager System Administrator's Guide.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
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Detailed VERICUT Configuration Tasks
Windows Start Menu License Administration Choices
The following describe the different Windows "Start Menu" choices under Start > All
Programs > CGTech VERICUT 9.0 > License Administration. Some of these choices only
display information and some require a Windows administrative user in order to make
changes to system settings.

License Utilities
"License Utilities" choices are intended to help setup licensing or diagnose license
problems on either the license server computer or the VERICUT client computer.
Display Local License Servers
View all Sentinel RMS license servers on this subnet. This choice uses the Sentinel
RMS lswhere utility to display all Sentinel RMS license servers that can be
communicated with. It uses Sentinel RMS's 'broadcast' feature to contact and collect
information about various Sentinel RMS license servers on the same subnet as the
current computer. It reports on any Sentinel RMS license servers, which may or may
not have VERICUT licenses. For more information about advanced license server
configuration options, see the
Sentinel - Sentinel RMS License Manager System Administrator's Guide.
Display Network Information
Check IP and Ethernet addresses of network devices on this computer. This choice
uses the Windows' command IPCONFIG /ALL to display important network
information, especially TCP/IP configuration information. This can be used to
determine if the TCP/IP configuration is valid (i.e. displays a valid IP address of the
current computer). It also shows if multiple network devices are present, and their
status.
Sentinel RMS License Administrator (WlmAdmin)
View licenses and status of running Sentinel RMS license servers using the Sentinel RMS
Windows’ license utility WlmAdmin. WlmAdmin is configured with the VERICUT license
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server identified during installation as a "Defined Server" in WlmAdmin's defined server
list. For more information about the WlmAdmin utility see the Sentinel RMS License
Manager System Administrator's Guide.

Specify License Server Computer
(requires privileges to write to the VERICUT installation folders)
Direct VERICUT to get its licenses from a different license server computer. The choice
opens the VERICUT configuration file, cgtenv.bat in Windows' Notepad text editor.
Comments in the file identify the LSHOST environment variable and how to change it to
specify a different VERICUT license server computer's host name. For more information
about the LSHOST environment variable see the
Sentinel RMS License Manager System Administrator's Guide.

License Server Only
"License Server Only" choices are only intended to be used on the license server
computer, to help setup licensing or diagnose license problems.
Configure License & Setup Server
NOTES:
1. Requires administrative privileges
2. If you are installing on a computer running Windows 7 Pro you will need to
do the following before continuing with the Configure License & Setup
Server steps.
•
•

Go to Control Panel > User Accounts > Change User Account
Control settings (aka UAC).
Change it from Default to Never notify

The Never Notify setting is to be used when using a program not
certified for Windows 7 because it does not support User Account
Control (like Sentinel or VERICUT).
This is typically the only selection used when setting-up a Windows license
server. It does the following:
1. Opens the Create License program and instructs the administrator to drag/drop the
VERICUT license email into the screen. This creates the 'cgtech.lf' license file in the
license folder.
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2. Sets the system environment variable LSERVOPTS to point to the license file just
created.
3. Removes any previous Sentinel RMS license server service, then adds and starts the
license server service from the current installation folder. When the server starts (via
the service) it looks for the license file defined in LSERVOPTS, and adds the license
keys.
Display Host ID
Display the Ethernet address of all enabled network adapters on this computer. The
user selects one of these displayed Ethernet addresses as the HOST ID used to lock
the license server to this computer. The program that displays the Ethernet
addresses uses the exact same logic as the license server program. When a license is
added to the license server program, it is compared against enabled network
adapters. If the network adaptor encrypted in the license key does not match any of
the enabled network adaptors, the key is not added to the license server.
Remove License Server Service
(requires administrative privileges)
Stops the license server and removes the license server service on this computer.
You can use Start License Server Service to restart a license server that is installed as
a service.
Run Temporary License Server
(requires administrative privileges)
Starts a temporary license server from the current user's login. You may use this
choice to temporarily start the license server program, such as for testing or if it is
not possible to add a service. The license server is temporary because it is
terminated when the user logs-out of the current session. Use Configure License &
Setup Server for a permanent installation of the server via Windows Services.
Save License File from License Email
(requires privileges to write to the VERICUT installation folders)
Creates the VERICUT license file from a license email or text file containing the
license keys. This choice opens a utility program that reads the license keys in the
CGTech license email and creates the cgtech.lf license file in the local installation's
'license' folder. The utility program reads the license email via:
1. Drag/drop the email directly from Microsoft Outlook or Outlook Express.
2. Drag/drop a saved email message file (.msg or .eml).
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3. Copy/paste the email's text. For example you can select all the text (typically
Edit > Select All in your email program), then paste it into the Create License
panel with the right-mouse menu > Paste menu button.
4. Drag/drop a plain text file saved from the license email.
The Create License panel's text area displays all the added license keys, followed by
the message "License file C:\cgtech82\windows\license\cgtech.lf created
successfully". The license server program reads the cgtech.lf license file when it
starts, and adds valid license keys to the running license server.
Set License File Environment Variable
NOTES:
1. Requires administrative privileges
2. If you are installing on a Windows 7 Pro computer you will need to do the
following before continuing with the Configure License & Setup Server steps.
• Go to Control Panel > User Accounts > Change User Account Control
settings (aka UAC).
• Change it from Default to Never notify
The Never Notify setting is to be used when using a program not certified
for Windows 7 because it does not support User Account Control (like
Sentinel or VERICUT).
Sets the LSERVOPTS system environment variable, used by the license server to find
the cgtech.lf license file when the Windows service starts the license server. This
setting is only used by the license server started as a Windows service. For more
information about LSERVOPTS and its options see the
Sentinel RMS License Manager System Administrator's Guide.
NOTE: A restart is required after the environment variable is changed.
Start License Server Service
(requires administrative privileges)
Stops and removes any existing license server service, then installs and starts the
license server service from the current installation. This choice is only effective when
using a license server service.
Stop License Server Service
(requires administrative privileges)
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Stops a running license server service on this computer. The service is not removed,
only stopped.
Update Licenses on Running Server
(requires administrative privileges if used on a license server service)
Causes the running license server to re-read the license file. The server must be
running when this selection is used. This selection uses the Sentinel RMS lslic
program to remove the current licenses, then re-reads the license keys in the
cgtech.lf license file and adds them to the running license server. For more
information about the lslic program see the Sentinel RMS License Manager System
Administrator's Guide.
Return to “Other Configuration Tasks”

57

Installing CGTech Products

Alternate Method to Determine Your Windows License
Server Computer’s HOST ID
If you do not have access to the VERICUT DVD you can display the HOST ID as follows:
•

Open a Command Prompt window (also called a DOS window)

•

Type in the window: Ipconfig /all

The value shown to the right of "Physical Address" is typically the HOST ID. Valid IDs are
12 characters and contain only the characters 0-9 and A-F. If your computer has multiple
network adapters, the license server program compares the address encrypted in the
license keys with enabled network adapters. If a network adapter address matching the
encrypted key address is found then the license is added to the server.
The following Physical Addresses are not valid, and indicate something is wrong with the
TCP/IP network protocol configuration for the Ethernet device, or indicates the card is
not enabled or available:
000000000000
204c4f4f5020
ffffffff
ffffffffffff
NOTE: The license server delivered with this version of VERICUT only requires the
device to be enabled. It no longer requires it to be connected or have an active
network transport such as IPX/SPX.
See the section on Check Windows Network Configuration if you are having trouble
getting a valid Physical Address.
Return to “Other Configuration Tasks”
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Check Windows Network Configuration
In any VERICUT installation there is a computer that functions as the license server
computer. There are also one or more client computers that run VERICUT and
communicate with the license server computer to get licenses. In a stand-alone
configuration the license server computer and the VERICUT client computer are one-inthe-same, but the same network communication requirements apply. The following
checks ensure that the license server computer and the VERICUT client computer(s) can
communicate, and that the VERICUT client computers can successfully run VERICUT.

Checks for both the License Server Computer and VERICUT Client
Computers
1. Check the network hardware.
Ensure that you have a network adapter installed and enabled on the license server
computer. You can use the Windows Device Manager (available under the Control
Panel's System icon) to see if you have an installed network adapter. The VERICUT
license keys are encrypted to match the physical address of an enabled network
adapter. When the license server program initially starts it finds enabled network
adapters and compares each license key with the physical address of the adapter(s).
If a match is found the license key is added to the license server.
2. Check the network software.
VERICUT and the license server program use TCP/IP network protocol to
communicate with each other, even when running VERICUT on a single stand-alone
computer (where both VERICUT and the license server program run on the same
computer). TCP/IP network protocol must be installed on the enabled network
adapter that matches the Host ID encrypted in your VERICUT license.
If you need to add TCP/IP protocol and your computer is on a company network you
should consult with your network administrator. If you are on a computer with no
network connection and you need help on how to add TCP/IP protocol, see the
section, Basic Windows Network Configurations.
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Checks for the License Server Computer
1. Serving licenses to other client computers.
In addition to having a network adapter and TCP/IP network protocol installed, the
license server computer must have a valid IP address in order to serve licenses to
other computers. A static IP address should be used. If a dynamic IP address is
assigned using a DHCP server, then VERICUT license check-out on client computers
may be slow and/or inconsistent. Static IP addresses are required for all license
server computers in a redundant server configuration.
Use the ipconfig command to verify there is an enabled network adapter with
TCP/IP protocol installed and that it is properly configured to be the license server
computer. Type the following command in a command prompt window (also called
a 'DOS' window):
ipconfig /all
The ipconfig command returns information about your computer's network
configuration. Only a few items are important for your VERICUT installation. If your
computer is connected to a network and TCP/IP protocol is installed and configured
correctly, the following lines should have values in order for the license server
program to provide licenses to VERICUT on another computer:
Host Name . . . . . . . . . . . .

: mycomputer

Physical Address. . . . . . . . . : 00-0B-AB-77-34-64
IP Address. . . . . . . . . . . .

: 199.1.1.123

Subnet Mask . . . . . . . . . . .

: 255.255.255.0

2. No network connection, stand-alone configuration.
If your computer is not connected to a network, or your computer is sometimes
disconnected from a network when you want to use VERICUT (thus it is a standalone configuration with VERICUT and the license server program running on the
same computer), then at a minimum you must have an enabled network adaptor.
When disconnected from a network, ipconfig may not display an IP address. This
does not cause a problem for VERICUT or the license server program because the IP
loopback address (127.0.0.1) is used automatically. A Host Name is required, but the
default name, "localhost" is sufficient.
The following values should be displayed by ipconfig for a stand-alone configuration:
Host Name . . . . . . . . . . . .

: mycomputer (or localhost)

Physical Address. . . . . . . . . : 00-0B-AB-77-34-64
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Checks for VERICUT Client Computers
1. Set the optimum color display for VERICUT
True or high color display provides optimum VERICUT performance. Desktop color
display is changed by opening the Display icon in the Control Panel, or by right-click
> Properties on the desktop.
NOTE: The following checks are not necessary for a stand-alone configuration where
VERICUT and the license server program run on the same computer.
2. Check the VERICUT client computer's network software configuration.
In addition to having a network device and TCP/IP network protocol installed, the
device must have a valid IP address (either statically assigned, automatically created,
or dynamically provided by a DHCP server).
Use the ipconfig command to verify that there is an active network device with the
TCP/IP protocol installed and that it is properly configured with a host name and IP
address. Open a command prompt window (also called a 'DOS' window) and type:
ipconfig /all
The ipconfig command returns information about your computer's network
configuration. Only a few items are important for your VERICUT installation. If your
computer is connected to a network, and TCP/IP protocol is installed and configured
correctly, the following lines must have values in order for VERICUT to work
correctly:
Host Name . . . . . . . . . . . .

: mycomputer

Physical Address. . . . . . . . . : 00-0B-AB-77-34-64
IP Address. . . . . . . . . . . .

: 199.1.1.123

Subnet Mask . . . . . . . . . . .

: 255.255.255.0

3. Verify client and license server computers can communicate with each other.
Both client and license server computers must have host names and valid IP
addresses. The mechanism for assigning host names and IP addresses varies with the
network configuration. See your site's network administrator if you are not familiar
with how your network is configured.
The easiest way to verify communication between computers is to "ping" each one
from the other. Open a command prompt window and type:
ping COMPUTER1
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(where 'COMPUTER1' is the host name of the computer you need to
communicate with)
If the computers can communicate you should see something like:
Pinging COMPUTER1 [199.1.1.123] with 32 bytes of data:
Reply from 199.1.1.123: bytes=32 time=48ms TTL=127
Reply from 199.1.1.123: bytes=32 time=46ms TTL=127
Reply from 199.1.1.123: bytes=32 time=43ms TTL=127
Reply from 199.1.1.123: bytes=32 time=41ms TTL=127
Ping statistics for 199.1.1.123:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 41ms, Maximum = 48ms, Average = 44ms
You should ping the client from the license server computer and the license server
computer from the client since both computers must know about each other for
proper communication. If the ping test fails contact your site's network
administrator to correct the problem.
In some network configurations there may be a router, gateway or other network
device that acts like a firewall between the client and license server computer. In this
case, the ping test will succeed but licensing will fail since the router or firewall must be
configured to allow TCP/IP to pass UDP packets through port 5093. For this and other
complex network configurations contact your site's network administrator and see the
Sentinel RMS License Manager System Administrator's Guide., for more information
about configuring the Sentinel RMS license server and clients
Return to “Other Configuration Tasks”
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Basic Windows Network Configurations
Use the appropriate section below to properly configure your network device for
VERICUT on Windows computers.

To check for network software on Windows XP Professional:
When using the Start Menu,
1. Taskbar: Start > Control Panel > Network Connections
2. Double click on the Device icon.
3. Select Support tab.
Installed software must include "Internet Protocol TCP/IP".
When using "classic" Start Menu,
1. Taskbar: Start > Settings > Network Connections
2. Double click on the Device icon.
3. Select Support tab
Installed software must include "Internet Protocol TCP/IP".
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Configuring VERICUT to Read an NX Part File
An NX part file can be opened directly in VERICUT. The following describe the
environment variables that need to be set.
The following environment variables need to be set in VERICUT's environment:
UGII_BASE_DIR
UGII_BASE_DIR is setup by an NX installation in the system environment space
and typically points to the place where NX is installed, for example C:/Program
Files/UGS/NX 6.0/.
UGII_ROOT_DIR
UGII_ROOT_DIR is setup by an NX installation in the system environment space
and typically points to the location of the NX executable files, for example
C:/Program Files/UGS/NX 6.0/UGII/.
Also, UGII_ROOT_DIR must be set in the execution path (the "path" environment
variable).
Additional requirements:
1. NX6, NX7, NX7.5, NX8, NX8.5 or NX9 must be installed on the computer that is
running VERICUT.
2. An NX license must be available.

Return to “Other Configuration Tasks”
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Other VERICUT Configuration Tasks
Following are configuration tasks that may need to be done depending on the CGTech
products you are using.
•

To configure CAD/CAM Interface modules, go to one of the following:
CATIA V5-to-VERICUT Interface for CATIA version 5
CATIAV6-to-Vericut Interface for CATIA/DELMIA V6
CATIA V5-to-VERICUT Drilling and Fastening Interface (CAT2VDAF)
CAMWorks to VERICUT Interface
EdgeCAM-to-VERICUT Interface
ESPRIT-to-VERICUT Interface
GibbsCam-to-VERICUT Interface (GibbsV)
Mastercam-to-VERICUT Interface (MCAMV)
NX-to-VERICUT Interface (NXV)
NX-to-VERICUT Drilling and Fastening Interface (NX2VDAF)
Pro/E-to-VERICUT Interface (PROEV)
SURFCAM to VERICUT Interface

•

To install the CAD Model Interface modules, go to Installing the Model Interface
Modules.

•

To enable VERICUT to read NX files directly, go to Configuring VERICUT to Read
an NX Part File

•

To configure the VERICUT TDM Interface, go to VERICUT TDM Systems Interface.

Following are other configuration tasks that may need to be done, depending on your
site's requirements.
•

Windows Start Menu License Administration Choices

•

Determine Your License Server's Host ID

•

Check Network Configuration

•

Change License Servers

•

Update an Existing License

•

Stop and Remove a License Server

•

Starting a Temporary License Server

65

Installing CGTech Products

•

Uninstall an old version of VERICUT

•

Download and Install the Latest Point Release for Windows

•

Installing Microsoft C++ redistributable run-time libraries for XP64

•

Configure Redundant License Servers on Windows

Move Windows License Server
It is sometimes desirable (or necessary), due to hardware upgrades or network changes,
to move your VERICUT license server to a different license server computer. To move
the license server in an existing installation, do the following:
1. Request a license for the new license server computer using CGTech's on-line
license Transfer Request form.
(Once you receive the license email containing your new license keys, continue
with the following steps.)
2. Stop and Remove the Windows License Server.
3. Follow the VERICUT Installation Steps to install VERICUT on the new license
server computer.
4. Modify VERICUT client computer installations to use the newly installed license
server computer.
Do step 4 for each VERICUT or VERICUT Composite Software installation in your
network.
Return to “Other Configuration Tasks”
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Modify VERICUT on Windows to Use a Different License
Server Computer
To change an existing VERICUT Windows installation to access VERICUT licenses on a
different license server computer:
1. Select Start > All Programs > CGTech VERICUT 9.0 > Utilities > Specify License
Server Computer (opens the file in Notepad)
2. Change the line:
set LHOST=server1
3. Replace "server1" (or the name of your old license server computer) with the
host name of the new license server computer.
4. Save the file cgtenv.bat.
Return to “Other Configuration Tasks”
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Update a License on Windows License Server
These instructions assume you have received a new license from CGTech via email. If
you have not, and you need to request a new license, see Determine the HOST ID and
Request a License. To update your VERICUT license on a Windows license server, do the
following (on the license server computer):
4. Create the license file from the license email or saved text file.
A. Select Start > All Programs > CGTech License Server > License Server Only > Save
License File from License Email.
B. Drag and drop the VERICUT license email from Microsoft Outlook, or Outlook
Express, into the Create License File panel. If you use another email program, or
cannot access the license email from the license server computer, then save the
license email as a "Text Only" or plain text file and drag/drop the saved file into
the Create License File panel.
C. Close the Create License File panel after the "success" message displays.
5. Update the licenses on the running license server.
Select Start > All Programs > CGTech License Server > License Server Only > Update
Licenses on Running Server. Do not attempt to do this action unless you know your
license server is running. If you are not sure, you can verify that the server is running
using Start > All Programs CGTech License Server > License Utilities > Display Local
License Servers. Your server's Host Name should appear in the resulting panel.
If errors occur, visit the VERICUT Users’ Forum or contact CGTech technical support via
our website, just click on the support link.

Return to “Other Configuration Tasks”
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Stop and Remove a Windows License Server
Only one license server can run on the license server computer. The license server from
the newest installed version should be used. The old license server should be stopped
and removed before configuring and starting the new license server.
Stop and remove a Windows license server service
NOTE: The following must be done by an Administrator user.
Start > All Programs > CGTech License Server > License Server Only > Remove License
Server Service
Stop and remove a temporary license server process
Right-mouse click on the SentinelLM task in the windows task bar, and choose Close.
Remove any mechanism which might have been configured to automatically start
the temporary server. For example, you may need to remove a shortcut to the
temporary server startup batch file from the Start > All Programs > Startup folder.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
Return to “Other Configuration Tasks”
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Starting a Temporary Windows License Server
The following describes how to start a temporary license server. But, it is strongly
recommended that you configure the license server program to automatically start
using Windows services. If for some reason you cannot configure the license server
service, then it can be temporarily started.
To start a temporary license server select:
Start > All Programs > CGTech License Server > License Server Only > Run
Temporary License Server.
You could add a Windows shortcut to your desktop to make access to this procedure
easier.
This Start menu item could also be added to the Windows Startup folder so that it
automatically starts when you log-in.
NOTES:
1. A temporary license server can only be started by an Administrator user.
2. The temporary license server process is owned by the specific user that starts it.
When that user logs-out, the license server program terminates.
3. Starting a temporary license server stops the Windows license server service if it
is running.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.

Return to “Other Configuration Tasks”

70

Installing CGTech Products

Uninstall an Old Version of VERICUT
Uninstalling is recommended when a VERICUT software version is no longer needed, or
when disk space is limited. Use the appropriate procedure below to remove a version of
VERICUT software from your computer.

To remove VERICUT software from a Windows computer:
1. Remove the license server service by selecting Start > All Programs > CGTech
License Server > License Server Only > Remove License Server Service. Do this
BEFORE uninstalling!
2. Unistall VERICUT by selecting Start > Programs > CGTech VERICUT x.x > Utilities
>Uninstall VERICUT x.x (where "x.x" is the version of VERICUT to be uninstalled)
and follow the prompts of the "uninstall" program. You can also start the
"uninstall" program using the UninstallVERICUT.exe, located in the
UninstallerData folder of your VERICUT software installation.

NOTE: There may be program folder/files that are not removed by uninstalling. These
were created after VERICUT was installed and will have to be removed manually.
During the uninstall process the following dialog may appear. You do not have to do a
system restart and may just press the “continue” button to proceed.

Return to “Other Configuration Tasks”
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Download and Install the Latest Point Release for
Windows
VERICUT point releases for Windows are available on the CGTech web site. The
following steps will guide you through downloading and installing a VERICUT point
release (we'll use 9.0 as an example below):
Download Instructions:
The VERICUT 9.0 Windows version (Windows 7, 64 bit) is available for download
from our web site. Follow this link to open the on-line form to begin the download
process:
http://www.cgtech.com/vericut_support/request-software-update/
To download the file, you will need your Company ID and the access code from the
"VERICUT 9.0 is available for download" email that was sent to all customers on
maintenance. If you are not currently on maintenance, contact your CGTech
representative.
Starting the Installation:
After downloading the zipped installer, unzip it to a temporary folder. The zip file is
password protected. The password was also included in the "VERICUT 9.0 is
available for download" email.
Once the files are unzipped, double-click on install.exe to begin the installation.
Return to “Other Configuration Tasks”
XP
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Install Microsoft redistributable C++ Run-Time Libraries
VERICUT on Win7 64 may require installation of the correct version of Microsoft’s C++
run-time libraries. You may also need to install the correct version of Microsoft’s C++
run-time libraries if you are installing the Model Interface Modules. The following
describes the 64 bit version of the libraries.
To install the libraries:
Get the vcredist_x64.exe installer:
The redistributable C++ run-time is available
•

On the VERICUT DVD. The file name is vcredist_x64.exe.

•

In the VERICUT installation in
C:\Program Files\cgtech\VERICUT 9.0\redist\vcredist_x64.exe,
where “C:\Program Files\cgtech\VERICUT 9.0\” is your installation location.

•

Download from CGTech’s download site at:
http://www.cgtech.com/vericut_support/system-requirements

Installation:
Double-click on vcredist_x64.exe to install. There are no prompts during
installation and no confirmation of completion. You must have Administrator
privileges to do the install.

Return to “Other Configuration Tasks”
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Configuring CAD/CAM to VERICUT Interfaces
Choose the interface you want to configure from the following:
CAMWorks to VERICUT Interface
CATIA V5-to-VERICUT Interface for CATIA version 5
CATIAV6-to-Vericut Interface for CATIA/DELMIA V6
CATIA V5-to-VERICUT Drilling and Fastening Interface (CAT2VDAF)
EdgeCAM-to-VERICUT Interface
ESPRIT-to-VERICUT Interface
GibbsCam-to-VERICUT Interface (GibbsV)
Mastercam-to-VERICUT Interface (MCAMV)
NX-to-VERICUT Interface (NXV)
NX-to-VERICUT Drilling and Fastening Interface (NX2VDAF)
Pro/E-to-VERICUT Interface (PROEV)
SolidWorks-to-VERICUT Interface
SURFCAM to VERICUT Interface
NOTE: If using the interface with VERICUT Single Platform you’ll need to add an
environment variable so that the interface will launch the correct version of VERICUT.
CGTECH_SINGLE_PLATFORM=YES

This variable may be added to your
Windows environment variables.
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Configuring the CAMWorks-to-VERICUT Interface
The CAMWorks interface requires that CAMWorks and SolidWorks are installed. In
addition, 3 environment variables need to be established.
To enable CAMWorks to find the necessary VERICUT files, you also need to define three
environment variables, CGTECH_INSTALL, CGTECH_PRODUCTS and LSHOST.
If you are using VERICUT single Platform then an additional environment variable needs
to be defined for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

Environment Variable
Name

Variable Value

CGTECH_INSTALL

C:\Program Files\CGTech\VERICUT x.x.x

CGTECH_PRODUCTS

C:\Program Files\CGTech\VERICUT x.x.x\windows64

LSHOST

server_name

CGTECH_INSTALL is set to the VERICUT installation folder. In the above table, x.x.x
represents the VERICUT release number. For a typical VERICUT 9.0 installation this
variable is set to C:\Program Files\CGTech\VERICUT 9.0\.
Defining a value explicitly for the CGTECH_INSTALL environment variable is optional. It
can be derived from the CGTECH_PRODUCTS environment variable value.
CGTECH_PRODUCTS is set to the folder for the specific operating system of the
computer running VERICUT: "windows64". In the above table, x.x.x represents the
VERICUT release number. For a typical VERICUT 9.0 installation this variable is set to
C:\Program Files\CGTech\VERICUT 9.0\windows64.
LSHOST is set to the name of the license server computer.
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.
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Accessing the CAMWorks-to-VERICUT Interface
In order to launch the interface from SolidWorks, click on Tools button in the
SolidWorks menu, and select the Macro->Run options as shown in the picture below.

Using the macro browse dialog that displays, navigate through CAMWorks interface
installation directory which may be located on the local computer, or on the network,
and select the Vericut_Interface.dll and then Open.
At the end of this process, the CAMWorks-to-VERICUT Interface window should display.

To add an icon to the CAMWorks Toolbar
Select the pull-down next to Options

icon and select Customize…
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Select Commands tab; Categories: Macro
Drag and drop New Macro Button

onto the CAMWorks Toolbar

Specify the location of the Vericut_Interface.dll

NOTE: For an Icon you can select C:\Program Files\CGTech\VERICUT
9.0\windows64\solidworks\vericut.ico
Select OK

Return to “Other Configuration Tasks”
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Configuring the CATIA V5-to-VERICUT Interface
Prerequisites
CATV5 requires CATIA V5 (R18 or later) and VERICUT 8.1 (or later).
It also requires two elements of Windows.
1. "Windows Script" should be version 5.6 or later. The latest version of Windows
Script is available from Microsoft's download site. Search for "Windows Script"
and pick the latest version offered. Note that there is one download for
Windows 2000 and XP, and another for 98, ME and NT.
2. Two dynamic link libraries, FM20.dll and FM20ENU.dll, which are distributed
with Microsoft Office. If some portion of Office is installed then FM20.dll and
FM20ENU.dll should already be present (in the "Windows\System32" folder or
an equivalent) and registered.

Configuration
The CGTech software installation procedure places the files required by CATV in a subfolder. If you elected to install the software in the default folder "C:\Program
Files\cgtech\VERICUT x.x.x\" (where x.x.x is the VERICUT release number), then for
VERICUT 9.0, the CATV folder will be "C:\Program Files\cgtech\VERICUT
9.0\windows64\catv5".
The one exception is the file "CATV.bat", which is located in the folder "C:\Program
Files\cgtech\VERICUT x.x.x\commands" (where x.x.x is the VERICUT release number).
The "CATV.bat" file sets at least two environment variables before invoking the
executable "CATV.exe" to start the CATIA V5-to-VERICUT Interface.
The first environment variable is CGTECH_PRODUCTS and it points to the platform
specific folder of the CGTech software. For CATV the platform is either "windows" or
"windows64". The second environment variable is CGTECH_LIBRARY and it points to the
folder containing VERICUT specific files distributed with the product. These include
"init.VcProject" and "initm.VcProject" which are used by "CATV.exe" as project and
setup templates if no other file is specified by the user.
The "CATV.bat" file is generated during the installation procedure and there should be
no need to edit the definition of either of these mandatory environment variables.
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The following optional environment variables are available for use in the CATV.bat file.
CGTECH_CATV_ALL_VISIBLE
This environment variable controls visibility of models transferred to VERICUT.
CGTECH_CATV_ALL_VISIBLE=No (Default if not set)
All instances of all CATParts within selected CATProducts are transferred. They are
marked as visible or hidden, so that the picture that first appears in VERICUT
matches that in CATIA.
CGTECH_CATV_ALL_VISIBLE=Yes
All design, stock and fixture models transferred to VERICUT will be visible, regardless
of their state in CATIA.
This environment variable can be set in a batch file that is used to launch CATV.
For example:
C:\Program Files\cgtech\VERICUT 9.0\windows64\CATV.bat
Add a line similar to the following near the beginning of the file:
set CGTECH_CATV_ALL_VISIBLE=Yes
CGTECH_CATV_FOLDER
This environment variable causes CATV to generate a number of files when it
communicates the details of a CATIA CATProcess file to VERICUT. These include tool
libraries, STL or VRML model files, and NC programs in APT or G-Code. Normally CATV
will offer to place these files in the same folder as the CATProcess file. You can override
this behavior interactively, but if you typically want all generated files to be placed in a
single (perhaps temporary) folder, you can use this environment variable to specify it.
CGTECH_CATV_LANGUAGE
If you want CATV's interface to use something other than US English, the variable can
specify a file of localized text. Versions for French and German and Japanese are
supplied.
CGTECH_LATHE_HOLDERS_AS_CATPARTS
Set to “Yes”, “Oui”, “Ja” or any word not beginning with “N”, to trigger behavior
implemented for Lathe holders. This includes looking for (A) a coordinate system called
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"Tool Holder Axis System" which defines a tool assembly’s gage point, and (B) a
“.CATPart” which defines a turning tool’s holder.

CGTECH_CATV_LATHE_HOLDER_PARENT_FOLDER
Used with the prior environment variable to indicate where the “.CATPart” files for
turning tool holders are to be found.
CGTECH_GAGE_IS_PARAMETRIC_LENGTH
Set to “Yes”, “Oui”, “Ja” or any word not beginning with “N”, to force use of the length
specified in the parametric definition of a holder as the gage length, even when the
holder’s geometry is overwritten by a “.CATPart” or “.CATProduct”. Otherwise the
height of the profile defined by the “.CATPart” or “.CATProduct” will be used.
CGTECH_CATV_BALL_CENTERS
Set to “Yes”, “Oui”, “Ja” or any word not beginning with “N” to ignore any driven points
specified for parametrically defined ball end mills and to replace them by a single driven
point at the ball center. This is a throw-back requested by one customer to mimic the
behavior we offered before Dassault added support for multiple driven points (and we
figured out how to access that information).
You can place a shortcut to the CATV batch file on your Windows Desktop. If you do so,
we suggest that you alter the properties of the shortcut so that it runs in a minimized
window. This will avoid having an almost empty command window on screen for the
batch process. An alternative is to trigger the batch file from an icon on one or more of
CATIA's toolbars. To assist in setting this up, there is a CATIA macro script in the CATV5
folder, called "CATV.CATScript". There are two icon files in sub-folders,
"Small\I_CATV.bmp" and "Normal\I_CATV.bmp".
If you wish to have an icon ( ) on a CATIA toolbar, the two icon files must be placed
where CATIA expects to find them. The paths depend on where you have CATIA
installed, but typically you will find a "small" and "normal" folder under "C:\Program
Files\Dassault Systemes\B22\win_b64\resources\graphic\icons". Place the two versions
of the CATV icon, both called "I_CATV.bmp", in the appropriate folders.
Adding the CATV icon (

) to a CATIA toolbar is a multi-step process;

1. Get CATIA V5 running.
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2. Make the "Advanced Machining" workbench active, either by accessing an
existing CATProcess file, or by initializing a new one. One or more of the
Manufacturing toolbars are likely to be suitable locations for the CATV icon.
3. Pick "Tools" > "Macro" > "Macros" from CATIA's menus.
4. In the "Macros" dialog, pick "Macro Libraries".
5. In the "Macro Libraries" dialog, set the "Library Type" to "Directories".
6. Pick "Add existing library ..." and select the folder containing the CATV.CATScript
file.
(for example, "C:\Program Files\cgtech\9.0\windows\catv5").
7. "Close" the "Macro Libraries" dialog.
8. "Close" the "Macros" dialog.
9. Pick "Tools" > "Customize ..." from CATIA's menus.
10. In the "Customize" dialog, bring the "Commands" tab to the front.
11. Select "Macros" from the left-hand list of "Categories".
12. Pick "CATV.CATScript" from the right-hand list of "Commands".
13. Click on the "Show Properties ..." button.
14. Pick the "..." button to the right of the "Icon:" label.
15. In the "Icon Browser" dialog you need to step through the pages of icons until
you find the one for CATV ( ). The icons are presented in alphabetic order of
their names, which you can see by allowing the mouse cursor to sit over an icon
for a brief period. The CATV icon ( ) will probably be on the twelfth page. Pick
it and "Close" the "Icon Browser".
16. Back on the "Customize" dialog, position the mouse cursor over the name of the
macro, CATV.CATScript, in the right-hand list, depress the left mouse button, and
drag the cursor to the toolbar where you want the icon to appear. It's counterintuitive, but you drag the macro name, not the icon! Repeat this step if you
want the icon to appear on more than one toolbar.
17. "Close" the "Customize" dialog.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the CATIA V5-to-VERICUT Interface. For
complete details on using the CATIA V5-to-VERICUT Interface, see CATIA V5-to-VERICUT
Interface, in the CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces,
located in the CGTech Help Library.
Return to “Other Configuration Tasks”
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Configuring the CATIA/DELMIA V6 to VERICUT Interface
CATV6 requires CATIA/DELMIA Version 6 or later. 64 bit Operating systems.
The Interface is launched by executing the CATV6 batch file located in the VERCICUT
installation, Commands folder
ex. C:\program files\cgtech\vericut 9.0\windows64\commands
You also may need to install the Microsoft redistributables file.
InstallDSSoftwareVC11Prerequisites_x86_x64.msi
It can be found in the spatial folder of your VERICUT installation.
Example:
C:\program files\cgtech\vericut 9.0\windows64\spatial\iopR25\redist
NOTE: You will need administrator privileges to install this file.
The batch file can also be launched via a CATScript from within CATIA.
Launch CatiaV6 R2013x or DelmiaV6 R2013x (used CatiaV6 in example):
1. Copy Normal and Small icons from C:\cgtech82\windows64\catv6\normal and
\small folders to
C:\Program Files\Dassault
Systemes\B214\win_b64\resources\graphic\icons\normal and \small folders
2. Select CATIA menus Tools > Macros > Macros (or ALT-F8)
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3. Select Macro Libraries ….

4. Library type: from pull-down select PLM Directories
5. Select Create New Library …

6. Select a Name, example VERICUT_Script, then select OK
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7. Select Close

8. From the Macros Window select Create

9. Macro Language: from pull-down select CATScript
10. Macro Name: enter name, example CATV6.CATScript

11. select OK
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12. Select Edit
13. Add the following line in between Sub CATMain() and End Sub
CATIA.SystemService.ExecuteBackgroundProcessus
"C:\cgtech82\windows64\commands\catv6.bat"

14. Select File > Save and then File > Exit
15. Macros window select Close
16. Select CATIA menus Tools > Customize > Commands tab > Categories: Macros
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17. Under the Commands column select CATV6.CATScript then select Show
Properties

18. Select

and choose the

VERICUT Icon from the list.

86

Installing CGTech Products

19. Close the Icons Browser window
20. From the Customize window select the Toolbars tab.

21. Select the desired Toolbar; example Standard and then select Add Commands
22. Select CATV6.CATScript and then select OK.
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23. Close the Customize window.

Return to “Other Configuration Tasks”
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Configuring the CATIA V5-to-VERICUT Drilling and
Fastening Interface (CAT2VDAF)
Prerequisites
CAT2VDAF requires CATIA V5 (R18 or later) and VDAF 7.1 (or later). It is available for the
64bit Windows platform.
It also requires two elements of Windows.
1. "Windows Script" should be version 5.6 or later. The latest version of Windows
Script is available from Microsoft's download site. Search for "Windows Script"
and pick the latest version offered.
2. Two dynamic link libraries, FM20.dll and FM20ENU.dll, which are distributed
with Microsoft Office. If some portion of Office is installed then FM20.dll and
FM20ENU.dll should already be present (in the "Windows\System32" folder or
an equivalent) and registered.
Configuration
The CGTech software installation procedure places the files required by CAT2VDAF in
“C:\Program Files\CGTech\VERICUT 9.0\windows64\CAT2VDAF".
The one exception is the file "cat2vdaf.bat", which is located in the folder "C:\Program
Files\cgtech\VERICUT 9.0\windows64\commands". The "cat2vdaf.bat" file sets at least
two environment variables before invoking the executable "cat2vdaf.exe" to start the
CATIA V5-to-VERICUT Drilling and Fastening Interface.
The first environment variable is CGTECH_PRODUCTS and it points to the platform
specific folder of the CGTech software. For CAT2VDAF the platform is "windows64". The
second environment variable is CGTECH_LIBRARY and it points to the folder containing
VERICUT Drilling and Fastening specific files distributed with the product. These include
"init.vdafproject" and "initm.vdafproject" which are used by "cat2vdaf.exe" as project
and setup templates if no other file is specified by the user.
The "cat2vdaf.bat" file is generated during the installation procedure and there should
be no need to edit the definition of either of these mandatory environment variables.
The following optional environment variables are available for use in the CATV.bat file.
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CGTECH_CATV_ALL_VISIBLE
This environment variable controls visibility of models transferred to VERICUT Drill and
Fastener.
CGTECH_CATV_ALL_VISIBLE=No (Default if not set)
All instances of all CATParts within selected CATProducts are transferred. They are
marked as visible or hidden, so that the picture that first appears in VERICUT Drill
and fASTENER matches that in CATIA.
CGTECH_CATV_ALL_VISIBLE=Yes
All Skin, Structure and Fxture models transferred to VERICUT Drilling and Fastening
will be visible, regardless of their state in CATIA.
This environment variable can be set in the batch file that is used to launch CAT2VDAF.
For example:
C:\Program Files\cgtech\VERICUT 9.0\windows64\cat2vdaf.bat
Add a line similar to the following near the beginning of the file:
set CGTECH_CATV_ALL_VISIBLE=Yes
CGTECH_CATV_FOLDER
This environment variable causes CATV to generate a number of files when it
communicates the details of a CATIA CATProcess file to VERICUT Drilling and Fastening.
These include STL or VRML model files. Normally CAT2VDAF will offer to place these
files in the same folder as the CATProcess file. You can override this behavior
interactively, but if you typically want all generated files to be placed in a single
(perhaps temporary) folder, you can use this environment variable to specify it.
In the cat2vdaf.bat file, remove the “rem” from the
set CGTECH_CATV_FOLDER=C:\Temp statement and specify the path to the desired
folder.
CGTECH_CATV_LANGUAGE
If you want CATV's interface to use something other than US English, the variable can
specify a file of localized text. Versions for French and German and Japanese are
supplied.
In the cat2vdaf.bat file, remove the “rem” from the appropriate
set CGTECH_CATV_LANGUAGE=… statement.
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You can place a shortcut to the cat2vdaf batch file on your Windows Desktop. If you do
so, we suggest that you alter the properties of the shortcut so that it runs in a minimized
window. This will avoid having an almost empty command window on screen for the
batch process.
You should now be ready to start using the CATIA V5-to-VERICUT Drilling and Fastening
Interface. For complete details on using the CATIA V5-to-VERICUT Drilling and Fastening
Interface, see CATIA V5-to-VERICUT Drilling and Fastening Interface, in the CAD/CAM
Interfaces section of Converters and CAD/CAM Interfaces, located in the CGTech Help
Library.
If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES
Return to “Other Configuration Tasks”
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Configuring the Edgecam-to-VERICUT Interface (Edgecam
2013 R1 & R2, 2014 R1 & R2-SU2, 2015 R1 & R2, 2016,
and 2017)
To automatically install the Edgecam to VERICUT interface (ECV), insert the VERICUT
installation DVD or navigate to the root folder of the downloaded VERICUT installer.
Next, run the edgecam_interface_install.exe and follow the on-screen instructions.

The Installer creates 3 environment variable on your system (example below)
•
•
•

CGTECH_INSTALL=c:\program files\cgtech\VERICUT 9.0
CGTECH_PRODUCTS= c:\program files\cgtech\VERICUT 9.0\windows64
LSHOST=<server name> or LocalHost

If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

The installer copies specific files to your Edgecam installation folder. (see table)

92

Installing CGTech Products

93

Installing CGTech Products

To add the VERICUT menu to the Edgecam main menu bar (2013
R1 – 2014 R2)
Note: A Transfer File VERICUT.commands is included, which can be imported
into Edgecam by using the Customise dialog
•

From Edgecam main menu bar, select View> Toolbars> Customize> Transfer
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•

Select Toolbar > Load then browse the
C:\Users\%USERPROFILE%\Documents\Planit\2014.20\Edgecam\cam\Support, Open

To launch the interface, switch to Manufacturing mode.
menu will appear in the toolbar.

. The VERICUT

At this Time you can configure the interface or run the interface.

Note: After running ECV, The Build Date message is written to the Feedback window

NOTE: Edgecam 2014R2 versions supported:
ECV currently requires that a specific version of Edgecam 2014R2 be installed. Below is a list Edgecam
2014R2 versions and their corresponding ECV files:
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2014R2 2014.20.0  ECV (U:\Applications\DailyBuilds\cgtech82\windows64\edgecam\ 2014R2)
2014R2 2014.20.1  ECV (U:\Applications\DailyBuilds\cgtech82\windows64\edgecam\ 2014R2SU2)

Note: error generated but VERICUT files output OK

2014R2 2014.20.2  ECV (U:\Applications\DailyBuilds\cgtech82\windows64\edgecam\ 2014R2SU2)

Note Known issue:
Symptom: Try to launch VERICUT interface and there is no response
Solution:
Edgecam 2014 R2SU2 interface not loading was caused by this file.
C:\Windows\SysWOW64\UTILS.DLL
Renaming this file will let the interface load the correct utils.dll “C:\Program Files
(x86)\Planit\Edgecam 2014 R2\cam\utils.dll”
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To add the VERICUT menu to the Edgecam main menu bar (2015
R1 – 2015 R2)
Select Customize Quick Access Toolbar > More Commands
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Select Choose commands from: > User Commands

Select Customize The Ribbon…
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Select User Commands

Select Active Ribbon > NC Code >
Select New Panel
Edit Name window > Name: VERICUT
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Select OK

Select VERICUT Export from the Commands column
Select Add to move it to the Active Ribbon column
Do the same for VERICUT Preferences

Select OK
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Select VERICUT Export, right mouse pick Edit Appearance
Button Text: Run VERICUT
Button Image: Browse
C:\Users\john_Doe\Documents\Planit\2015.10\Edgecam\Themes\Default\ribbon\vericut.ico
Check Always large image (32*32)

Select OK
Set up image for VERICUT Preferences
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Launch Edgecam:
Use desktop shortcut
Open .ppf file

Launch interface:

Select the VERICUT Prefrences
Display Mode: Full
Select the Run VERICUT

icon

icon
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2015R1 2015.10.0 
C:\PROGRAM FILES\CGTECH\\vericut 9.0\windows64\edgecam\2015R1)
2015R1 2015.10.1
C:\PROGRAM FILES\CGTECH\\vericut 9.0\windows64\edgecam\2015R2)
Note Known issue:
Symptom: Error Internal error; Unable to load DLL “mch_reader.dll’
Solution: Install the Windows C++ run-time libraries (Microsoft Redistributables).
The Microsoft Redistributable Installer is also available for download at:
http://www.cgtech.com/vericut_support/system-requirements
Return to “Other Configuration Tasks”
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Configuring the ESPRIT-to-VERICUT Interface
Automatic Installation
To automatically install the Esprit to VERICUT interface, insert the VERICUT installation
DVD or navigate to the root folder of the downloaded VERICUT installer. Next, run the
esprit_interface_install.exe and follow the on-screen instructions.
NOTE: You must have Administrator privileges to install the Esprit to VERICUT
interface.
Next, you will need to register your files with the Windows registry and with ESPRIT so
that it will be able to find the Add-In when starting up.
You will need to double-click the file register-vericut-addin-64.reg. After doubleclicking the file, you will be asked to confirm if you want to add an entry to the registry.
Select yes and you should receive a confirmation message that the value was added
successfully to the registry.
NOTE: You must have Administrator privileges run register-vericut-addin-64.reg.
The other file you need to run is register-dll.bat. You will first need to edit this file to
point to your specific ESPRIT AddIns folder. To edit, you must right-click and select Edit,
choosing Notepad to edit it with if prompted. By default, the folder specified is the
default install location for ESPRIT. Even if you have ESPRIT installed in the default
location, it is strongly recommended to double-check that the folder specified in
register-dll.bat is the same folder where you copied the files previously. If you need to
edit the install location, only change text on the line highlighted in red below:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe "C:\Program Files
(x86)\D.P.Technology\ESPRIT\Addins\VericutAddin\VericutAddin.dll" /codebase /tlb
For example, if you have ESPRIT installed under T:\Applications\cad_cam\, the line in
your file would look like this:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe
"T:\Applications\cad_cam\D.P.Technology\ESPRIT\Addins\VericutAddin\VericutAddin.dl
l" /codebase /tlb
Also keep in mind that all the above text should be on the same line. It's only split onto
multiple lines in Word. When you're done editing, save and close the file, then doubleclick to run it. You should see a console window with the text from the file in it. This will
tell you if there were any problems running the script.

104

Installing CGTech Products

NOTE: You must have Administrator privileges run register-dll.bat.
Now you just need to enter a few environment variables to complete the installation.

Manual Installation
The following section describes how to install the ESPRIT-to-VERICUT Interface without
using the installer. ESPRIT requires that Add-Ins write values to the registry, because of
this, you must have administrator privileges to run these scripts.
First, create a directory named VericutAddin in your ESPRIT AddIns folder. If you have
ESPRIT installed in the default location, the folder you will need to create will be at
C:\Program Files (x86)\D.P.Technology\ESPRIT\AddIns\VericutAddin.
Next, copy all the provided source files into your VericutAddin directory. For reference,
here is the list of files you should copy:

Next, you will need to register your files with the Windows registry and with ESPRIT so
that it will be able to find the Add-In when starting up.
You will need to double-click the file register-vericut-addin-64.reg. After doubleclicking the file, you will be asked to confirm if you want to add an entry to the registry.
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Select yes and you should receive a confirmation message that the value was added
successfully to the registry.
NOTE: You must have Administrator privileges run register-vericut-addin-64.reg.
The other file you need to run is register-dll.bat. You will first need to edit this file to
point to your specific ESPRIT AddIns folder. To edit, you must right-click and select Edit,
choosing Notepad to edit it with if prompted. By default, the folder specified is the
default install location for ESPRIT. Even if you have ESPRIT installed in the default
location, it is strongly recommended to double-check that the folder specified in
register-dll.bat is the same folder where you copied the files previously. If you need to
edit the install location, only change text on the line highlighted in red below:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe "C:\Program Files
(x86)\D.P.Technology\ESPRIT\Addins\VericutAddin\VericutAddin.dll" /codebase /tlb
For example, if you have ESPRIT installed under T:\Applications\cad_cam\, the line in
your file would look like this:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe
"T:\Applications\cad_cam\D.P.Technology\ESPRIT\Addins\VericutAddin\VericutAddin.dl
l" /codebase /tlb
Also keep in mind that all the above text should be on the same line. It's only split onto
multiple lines in Word. When you're done editing, save and close the file, then doubleclick to run it. You should see a console window with the text from the file in it. This will
tell you if there were any problems running the script.
NOTE: You must have Administrator privileges run register-dll.bat.
Now you just need to enter a few environment variables to complete the installation.
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Environment Variables
In order to use the ESPRIT-to-VERICUT interface, you also need to define four
environment variables, CGTECH_INSTALL, CGTECH_PRODUCTS, LSHOST and
CGTECH_LANGUAGE.
If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

For example:
Environment Variable Name

Variable Value

CGTECH_INSTALL

C:\Program Files\cgtech\VERICUT x.x.x

CGTECH_PRODUCTS

C:\Program Files\cgtech\VERICUT x.x.x\windows64

LSHOST

server_name

CGTECH_LANGUAGE

C:\Program Files\cgtech\VERICUT x.x.x\windows64\ Esprit\language

CGTECH_INSTALL is set to the top level folder where VERICUT is installed. In the above
table, x.x.x represents the VERICUT release number. For VERICUT 9.0 the environment
variable would be set to C:\Program Files\cgtech\VERICUT 9.0.
CGTECH_PRODUCTS is set to the folder for the specific operating system of the
computer running VERICUT: either "windows" or "windows64". For a typical VERICUT
9.0 installation this variable is set to:
C:\Program Files\cgtech\VERICUT 9.0\windows64.
LSHOST is set to the name of the license server computer.
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CGTECH_LANGUAGE is used to specify the \path\ to the folder containing the Esprit-toVERICUT Interface language file (EspritRes.local) that you want to use.
Use the Microsoft Windows Control Panel > System > System Properties: Advanced
tab, Environment Variables feature to define these environment variables. See
Microsoft Windows Help for more information.

License
At the time that the ESPRIT-to-VERICUT Interface is launched for the first time, it tries to
connect with license server. License server name can be specified by environmental
variables LSHOST or LSFORCEHOST.
If neither of these two environment variables is defined, the window shown below will
display, enabling you to specify the license server name manually. The Name specified
will be saved for future use, so that you only have to define the license server name
once.

Language
At the time that the “VericutAddin.dll” is loaded with ESPRIT CAM system, the ESPRITto-VERICUT Interface looks for CGTECH_LANGUAGE environment variable. If it is
defined, the interface loads the “EspritRes.local” file found at that location.
If the CGTECH_LANGUAGE environment variable is not set, then the ESPRIT-to-VERICUT
Interface looks for the CGTECH_LOCALE environment variable to get the name of the
language file.
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If the CGTECH_LOCALE environment variable is defined, the ESPRIT–to-VERICUT
Interface will look for the “EspritRes.local” file in the folder where “VericutAddin.dll” is
located, in a subfolder named the same as the language that you want to use.
If the location of the language file is not found in any of these places, English will be
used as the application language. Also, if the “EspritRes.local” file for specified language
is not found, English will be used as the application language.

VERICUT Installation Directory
The ESPRIT-to-VERICUT Interface needs to know where VERICUT is installed and
whether it is a windows or windows64 version. Use the CGTECH_PRODUCTS
environment variable to provide this information. For example, set CGTECH_PRODUCTS
to “C:\Program Files\cgtech\VERICUT 9.0\windows64”.
Use the CGTECH_INSTALL environment variable to specify the location of the VERICUT
installation. For example, set CGTECH_INSTALL to “C:\Program Files\cgtech\VERICUT
9.0\”.
Initially the ESPRIT-to-VERICUT Interface will look for the environment variable
CGTECH_PRODUCTS. If it is defined, then execution continues, otherwise the following
window displays, enabling you to specify the location of the “commands” folder of your
VERICUT installation. Enter the \path\ to the “commands” folder of your VERICUT
installation in the VERICUT Command Path: text field or use the
(Browse) icon to
display a directory selection window and use it to specify the \path\ to the “commands”
folder.
For example, “C:\Program Files\cgtech\VERICUT 9.0\windows64\commands”.
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Based on the path that you provide, the value for CGTECH_PRODUCTS is determined.
You only need to specify the path the first time that the ESPRIT-to-VERICUT Interface is
used. The value of CGTECH_PRODUCTS will be saved for future use.
The location of the VERICUT installation will be retrieved from the CGTECH_INSTALL
environment variable, if defined, or will be determined from the value of
CGTECH_PRODUCTS.
If either of these variables remains undefined, the ESPRIT-to-VERICUT Interface will not
load up.

Troubleshooting
If the ESPRIT-to-VERICUT Interface does display in the Tools menu in ESPRIT, it needs to
be reloaded. This issue can be resolved by following the steps below:
•
•

Select ‘Tools =>Add-In’. It will bring up the Add-In manager in ESPRIT.
Click on the VERICUT Interface entry, and check both boxes under ‘Load
Behavior’.
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If there is no entry for the VERICUT Interface in the available add-ins list, there is most
likely a problem with registering the Interface.

Return to “Other Configuration Tasks”
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Configuring the GibbsCam-to-VERICUT Interface (GibbsV)
NOTE: The GibbsCam-to-VERICUT Interface (GibbsV) requires at least Gibbs 2010
V9.5.2.2.
NOTE: When installing this interface, the program should be run under an
Administrator account in order to minimize errors in the installation process.
The GibbsV-to-VERICUT Interface is distributed as two files;
GibbsV.dll (the code)
Gibbsv[language].local (localization file)
Supported localization files:
GibbsvChinese.local
GibbsvEnglish.local
GibbsvFrench.local
GibbsvGerman.local
GibbsvItalian.local
GibbsvJapanese.local
GibbsvSimplifiedChinese.local
GibbsvTraditionalChinese.local
The GibbsV.dll file should be placed in the GibbsCAM plugins directory. The localization
file should be placed under the “CGTECH_PRODUCTS\GibbsV” directory.
For a typical VERICUT installation, these files are located in the C:\Program
Files\CGTech\VERICUT 9.0\windows64\GibbsV.
The EditCode.gif file, EditPost.gif file, and the GibbsV.dll file should be placed in the
GibbsCAM plugins directory (for example, C:\Program
Files\Gibbs\GibbsCAM\9.0_NLO\plugins\.

NOTE: EditCode and EditPost have been removed from V9.0 onwards.
The localization file should be left in the \GibbsV\ directory of your VERICUT installation
directory.
The GibbsCAM-to-VERICUT Interface must have the following three environment
variables, CGTECH_PRODUCTS, LSHOST and GIBBSV_LANGUAGE set before using.
If you are using VERICUT single Platform then an additional environment variable needs
to be defined for the interface.
•

CGTECH_SINGLE_PLATFORM=YES
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Environment Variable Name

Variable Value

CGTECH_PRODUCTS

C:\Program Files\cgtech\Vericut x.x.x\windows64

LSHOST

server_name

GIBBSV_LANGUAGE

C:\program files\cgtech\vericut x.x.x\windows64\GibbsV
<select language>

CGTECH_PRODUCTS is set to the folder for the specific operating system of the
computer running VERICUT: "windows64". In the above table, x.x.x represents the
VERICUT release number. For a typical VERICUT 9.0 installation this variable is set to
C:\Program Files\cgtech\VERICUT 9.0\windows64.
LSHOST is set to the name of the license server computer.
GIBBSV_LANGUAGE is set to the folder where the GibbsV language localization files are
located. In the above table, x.x.x represents the VERICUT release number. For a typical
VERICUT 9.0 installation this variable is set to C:\Program Files\CGTech\VERICUT
9.0\windows64\GibbsV\GibbsCAM xxx\GibbsVlanguage.local (where language is
English, French, German, etc.).
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.

Accessing the GibbsCAM to VERICUT Interface

To start the GibbsCAM to VERICUT Interface from within GibbsCAM, click Plug-Ins in the
GibbsCam main menu, then select VERICUT from the pull-down list.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the GibbsCAM-to-VERICUT Interface. For
complete details on using the GibbsCAM-to-VERICUT Interface, see GibbsCAM-toVERICUT Interface (GibbsV), in the CAD/CAM Interfaces section of Converters and
CAD/CAM Interfaces, located in the CGTech Help Library.
Return to “Other Configuration Tasks”
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Configuring the Mastercam-to-VERICUT Interface
Configuring the Mastercam-to-VERICUT Interface
(MCAMV - Version X4, X5, X6, X7, X8 and X9).
NOTE: The VERICUT 9.0 release has Mastercam Interface Installation options for
Mastercam X6 through X9 that automatically install the interface files and set the
necessary environment variables for the Mastercam Interface. A standalone Mastercam
Interface installer is also available on the DVD or in the downloaded installation folder
called mastercam_interface_install.exe. If you have used the automatic installation then
jump directly to the Mastercam environment variable section.
Using Mastercam's terminology, the interface between MastercamXv (where v is the
Mastercam version number) and VERICUT is a Net-Hook. It can be invoked while running
Mastercam, transfers internal Mastercam data to files recognized by VERICUT, and fires
up VERICUT ready to perform verification of the NC programs. You can opt to verify
Mastercam's Intermediate NC data (NCI) or the G-code files produced by Mastercam's
post-processors.
NOTE: MCAMV requires the installation of the Microsoft C++ run time environment.
This is not distributed automatically by Microsoft. A copy of the installer is on the
VERICUT DVD, or at:
http://www.cgtech.com/vericut_support/system-requirements
Administrator privileges are required to install this.
You do not need this if you have Microsoft Visual Studio C++ 2005 installed (not likely
for most VERICUT users).

Configuration
The VERICUT C-Hook is for Mastercam Xv. It is distributed as five files located in the
C:\Program Files\cgtech\VERICUT x.x.x\windows64\mcamv\Xv\ directory of your
VERICUT installation. The x.x.x represents the VERICUT release number.
VERICUT.dll (the code)
VericutSupport.dll (supporting code)
SetStock.dll (gets the parameters for a Lathe Stock from Mastercam source code)
VERICUT.ft (used to map an Icon into the Mastercam menu interface)
mcRes.local (language translation)
The three .dll files and the .ft file should be placed in Mastercam's "chooks" folder,
which is one level down from the Mastercam installation folder (for example
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C:\McamX\chooks). The file mcRes.local should be placed in the Mastercam installation
folder.
To enable the C-Hook to find VERICUT, you also need to define three environment
variables, CGTECH_INSTALL, CGTECH_PRODUCTS and LSHOST.
If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

For example;
Environment Variable Name

Variable Value

CGTECH_INSTALL

C:\Program Files\cgtech\VERICUT x.x.x

CGTECH_PRODUCTS

C:\Program Files\cgtech\VERICUT x.x.x\windows64

LSHOST

server_name

CGTECH_INSTALL is set to the top level folder where VERICUT is installed. In the above
table, x.x.x represents the VERICUT release number. For a typical VERICUT 9.0
installation the environment variable would be set to C:\Program Files\cgtech\VERICUT
9.0.
CGTECH_PRODUCTS is set to the folder for the specific operating system of the
computer running VERICUT: either "windows" or "windows64". For a typical VERICUT
9.0 installation this variable is set to C:\Program Files\cgtech\VERICUT 9.0\windows64.
LSHOST is set to the name of the license server computer.
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.

Optional environment variables are for use MCAMV.
CGTECH_MCAM_FOLDER
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The environment variable CGTECH_MCAM_FOLDER can be used to set the MCAMV
Working Directory.
For example,
set CGTECH_MCAM_FOLDER=C:\CGTech\McamV_working\tmp
It may be convenient for those who want to have the same Output Directory for all
MCAMV projects.

CGTECH_DEFAULT_PROJECT
The environment variable CGTECH_DEFAULT_PROJECT can be used to set the MCAMV
Project Template.
For example,
Set CGTECH_DEFAULT_PROJECT=C:\McamV_working\VCtemplate\MCAMV_Template.vcproject

It may be convenient for those who want to have the same Project Template for all
MCAMV projects.

CGTECH_MCAM_NOTE_LEVEL
The environment variable CGTECH_MCAM_NOTE_LEVEL can be used to set the
Mastercam level for storing "notes" (saved MCAMV attributes). The default level is
3987. The custom level can be used in the unlikely event the default level is already
used, or is unsuitable for some other reason.
CGTECH_MCAM_IGNORE_NOTES
The environment variable CGTECH_MCAM_IGNORE_NOTES can be set to 1 if you do not
wish MCAMV to use the stored attributes. If this variable is set to 0, or not set, the
stored attributes are used to populate the MCAMV dialog fields.
CGTECH_MCAM_NOTE_COLOR
The environment variable CGTECH_MCAM_NOTE_COLOR can be used to set the
attributes color to something different from the default 0 (which is black). This was
added to eliminate warnings produced because at the notes level the background color
was also black. The color itself does not matter since the notes are not visible.
For example,
"set CGTECH_MCAM_NOTE_COLOR=1" to resolve a similar problem.
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CGTECH_MCAMV_TLNO_IS_SLOT
The environment variable CGTECH_MCAMV_TLNO_IS_SLOT was added to aid in
obtaining correct tool ID's from older part files.

Access
To trigger the Net-Hook while in Mastercam, hold down the Alt key and click the C key
(referred to as Alt-C). Alternatively, you could select Settings > Run User Application.
You will see a file selection dialog offering all the installed C-Hooks. Pick VERICUT.dll and
click on the Open button.

Setting up a VERICUT icon in Mastercam X4, X5, X6 and
X7 user interface

In Mastercam main window, select Settings > Customize
1. In Customize window, change Category to NET Hook
2. Select the VERICUT icon in the "Commands" area, and drag and drop it onto the
toolbar in the Mastercam main window
3. In the Customize window, in the Toolbars list, right click on "New Toolbar" and
select Rename Toolbar, rename it to something like Run VERICUT, then Enter.
4. Select the Diskette (Save As) icon, save as filename.mtb , OK
5. Click on the checkmark (OK) button to close the Customize window.
In Mastercam main window, select Settings > Configuration
1. In the System Configuration window, under Topics, select Start / Exit.
2. Under Startup Settings, point Toolbars to the filename.mtb file that you created
above. Either enter the /path/filename in the text field or click on the File
Cabinet icon (Select) and use the window that displays to select the file.
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3. Click on the checkmark (OK) button to close the System Configuration window.
4. If prompted: "Save Settings to Configuration File?", Yes.
See Mastercam Help for additional information.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the Mastercam-to-VERICUT Interface. For
complete details on using the Mastercam-to-VERICUT Interface, see Mastercam-toVERICUT Interface (MCAMV), in the CAD/CAM Interfaces section of Converters and
CAD/CAM Interfaces, located in the CGTech Help Library.
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Setting up a VERICUT icon in Mastercam X8 & X9
How to configure a MCAMV icon: X8 / X9
Add icon to toolbar steps:
Settings > Customize
Customize window > Select desired Workspace
Toolbars > Category: NetHook
Select Run VERICUT > Add > OK
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Add icon to right click menu steps:
Settings > Customize
Customize window > Select desired Workspace
Context Menu > Category: NetHook
Select Run VERICUT > Add > OK

Return to “Other Configuration Tasks”
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Setting up a VERICUT icon in Mastercam 2017
To add a VERICUT icon to the Mastercam window, perform the following:
1. In the Mastercam main window, right click on the ribbon bar and selected either
Customize the Ribbon from the right click menu that populates. This opens the
Options window.

2. In the Options window, select New Tab. A New Tab (Custom) will appear with a
New Group (Custom) populating beneath it in the Main Tabs section of the
Options window.

121

Installing CGTech Products

3. Use your mouse to highlight New Tab (Custom) then select Rename. Change the
name of the tab then repeat this process with New Group (Custom). In the
examples below, the tab and group have both been renamed to VERICUT.
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4. Go to the Choose command from: section and select Commands Not in the
Ribbon from the pulldown menu. In the list that populate beneath the pulldown
menu, highlight Run VERICUT.

5. Highlight the new group as shown below, then select Add to move the command
into the group. Select OK to save this configuration.
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6. The new tab now appears with the new group in the ribbon bar and when it is
selected, the Run VERICUT icon will be displayed.
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Configuring the NX-to-VERICUT Interface (NXV)
This section documents supported versions of NX, and the procedure for configuring the
NX-to-VERICUT Interface (NXV). These instructions apply only when VERICUT will be run
via NXV. If VERICUT will only be run outside of NX, then ignore this section.

NX version support
NXV can be operated on Windows computers with NX versions NX6, NX7, NX7.5, NX8,
NX8.5, NX9 and NX10.
VERICUT Interfaces for old Unigraphics versions (V16, V17, V18, NX, NX2, NX3, NX4 and
NX5) are no longer distributed with the VERICUT installation. You can copy the old
interface files forward from a previous installation, or contact VERICUT technical
support for the older Unigraphics interface files.
Upward compatibility of the old interfaces is not tested with this release and not
guaranteed. However nothing is intentionally changed to prevent them from continuing
to work.

Configuration
Follow the general procedure below to configure NXV. Integrating NXV into your
standard UG startup may require "root" or administrator permissions - see your system
administrator for assistance.
NOTE: The following NX products, ufunc_execute (P2_ufunc_execute for NX2, product
name "UG/Open API Execute") and the grip_execute (product name "UG/Open Grip
Execute") are required for NXV.
Assuming NX is installed, install VERICUT (includes the NXV software) per the VERICUT
installation instructions.
Windows
1. Locate the NXV batch file for your version of NX
Look in VERICUT’s 'commands' folder (C:\Program Files\cgtech\VERICUT
9.0\windows64\commands\ directory of your VERICUT installation. For the batch
file named nxV.bat (where V represents the NX version, i.e. nxv.bat, nx8.bat,
nx9.bat, etc). The batch file sets the environment for NXV, then runs NX using
%UGII_ROOT_DIR%\UGII.BAT.
NOTE: If you need a batch file for a newer/higher version of NX use the highest
nxV.bat available in the folder. The interfaces are usually upward compatible
with newer versions of NX.
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The following optional environment variables are available for use in the nxV.bat
(where V represents the NX version, i.e. nx2.bat, nx3.bat, nx4.bat, etc.) file.
CGTECH_NXV_OUTPUTDIR
The environment variable CGTECH_NXV_OUTPUTDIR can be used to set the NXV
Output Directory.
Example:
set CGTECH_NXV_OUTPUTDIR=C:\CGTech\nxv\working\tmp
It may be convenient for those who want to have the same Output Directory for
all NXV projects.
CGTECH_NXV_PREFSDIR
Environment variable CGTECH_NXV_PREFSDIR can be used to specify the
location of the NXV preferences file.
Example:
Set CGTECH_NXV_PREFSDIR=C:\CGTech82\nx
If CGTECH_NXV_PREFSDIR is not set NXV will attempt to use the preferences file
in the default location %HOMEDRIVE%%HOMEPATH%.
CGTECH_NXV_PROJTEMPLATE
The environment variable CGTECH_NXV_PROJTEMPLATE can be used to set the
NXV Project Template.
Example:
set CGTECH_NXV_PROJTEMPLATE=C:\CGTech\nxv\working\NXV_Template.vcproject

It may be convenient for those who want to have the same Project Template for
all NXV projects.
If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

126

Installing CGTech Products

2. Create a desktop shortcut to the batch file
Create a desktop shortcut that points to the NXV batch file found in step 1. Set
the shortcut's start-in property to a folder where the user has write permission.
You can optionally copy the batch file to a folder where you have write
permission and run it directly from there.
NOTE: The NXV batch file will NOT work correctly from its location in the
VERICUT’s ‘commands’ folder because users usually do not have write
permissions there. You must either create a desktop shortcut with a start-in path
where you have write permissions, or copy the batch file to a directory where
you have permission to write files.
NOTE FOR NX SYSTEM ADMINISTRATORS: To integrate the NXV interface into
your normal NX startup process, copy the environment settings from NXxx.bat
into your normal NX startup process. Do not copy the line that runs NX.

Start NX with NXV.
After completing the previous steps and assuming VERICUT is licensed and operational,
run NX using the batch file short cut. If NX does not start, DO NOT CONTINUE - see your
system administrator for assistance.
Depending on the version of NX, NXV is accessed differently. See the help on using NXV
in the Converters and CAD/CAM Interfaces section, in the CGTech Help Library, for
details.

Configuring NXV to start VERICUT with a custom Project file
If no Project Template is specified in the NXV interface dialog, NXV initializes VERICUT
with the following project from VERICUT’s Library folder:
•

init.VcProject (inch NX session)

•

initm.VcProject (millimeter NX session)

The interface adds models, NX program(s), and tools from the current session, and then
runs VERICUT.
You can change VERICUT’s default settings by modifying init.Vc Project (or
initm.VcProject). We recommend you save a backup copy of these files before
modifying them. The files are located in the "library" folder in your VERICUT installation.
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If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the NX-to-VERICUT Interface. For complete
details on using the NX-to-VERICUT Interface, see NX-to-VERICUT Interface (NXV), in the
CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces, located in the
CGTech Help Library.
Return to “Other Configuration Tasks”
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Setting up NXV to work with Teamcenter
Overview
Teamcenter (formerly IMAN and UG Manager) is a Product Lifecycle Management (PLM)
application that manages NX data files. When using the NX-to-VERICUT Interface (NXV),
it is necessary to modify the NX Teamcenter environment in order for NXV to operate
correctly.
NXV uses Teamcenter functions for reading data and writing files when running within
Teamcenter. For example:
•

If Teamcenter is not used, NXV asks NX to write VERICUT model files to the path
specified in the NXV interface.

•

If Teamcenter is used, NXV asks Teamcenter to ask NX to write model files.
Teamcenter then places the files in a "temporary" Teamcenter folder.

NXV detects when it is running within Teamcenter and uses Teamcenter data
management functions when requesting and writing data.
All VERICUT files for the current session are placed by Teamcenter in the "temporary"
Teamcenter folder for the current checked-out project. At the end of the NX session,
Teamcenter prompts the user to check the files in.
VERICUT files are considered, "meta-data" by Teamcenter. "meta data" is data with
unknown content, but the files are controlled by Teamcenter.

Implementing NXV in a Teamcenter installation
NOTE: The following example shows modifying a Teamcenter windows batch file for
NX2 on Windows, but the concept is the same for later NX versions.
The Teamcenter startup batch file (in this example, START_UGMANAGER.BAT) sets the
environment for starting NX2 with Teamcenter on Windows. The Teamcenter startup
batch file must be modified to call the modified NXV batch file (nx2.bat, nx3.bat, etc,
depending on your version of NX) from VERICUT’s commands folder.
1. Modify 4 lines in NXV’s startup batch file.
Add rem at the beginning of the following lines in the nxv.bat file. Where v is the
NX version number.
rem setlocal
rem set CGTECH_INSTALL=C:\Program Files\cgtech\VERICUT 9.0
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rem "%UGII_ROOT_DIR%\UGII.BAT" %argstr%
rem endlocal
See the red text in the example modified nx7_5.bat file below.
2. Call the NXV batch file (as modified in step 1) from the Teamcenter startup
script. The call must be inserted above the command that launches NX. Calling
the NXV batch file sets the environment for NXV and VERICUT from the
Teamcenter startup script. This edit is usually done by the Teamcenter site
administrator.
Example lines to add to a Teamcenter startup batch file that uses Windows batch
file syntax:
set CGTECH_INSTALL= C:\Program Files\cgtech\VERICUT 9.0
call "%CGTECH_INSTALL%\windows\commands\NX2"
3. The Teamcenter site administrator needs to configure Teamcenter to recognize
VERICUT files as "meta-data". An entry must be made for each extension
(.VcProject .mch, .ctl, .tls, .opti, .swp, .sor, .vct, etc?) These files will be managed
by Teamcenter.
NOTE: Two temporary files are created by NXV, but do not need to be managed
by Teamcenter. They have extension .opts and .vctemp.
Sample edited nx7_5.bat file
(the four edited lines are highlighted red)
@echo off
rem setlocal
rem set CGTECH_INSTALL=C:\Program Files\cgtech\VERICUT 9.0
rem

CGTech, Copyright, All Rights Reserved

rem CGTech environment
set CGTECH_PRODUCTS=%CGTECH_INSTALL%\windows
call "%CGTECH_PRODUCTS%\commands\cgtenv"
rem set CGTECH_IGNORELAST=TRUE
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set CGTECH_CLASSES=%CGTECH_INSTALL%\classes
if "%CGTECH_LIBRARY%" == "" set CGTECH_LIBRARY=%CGTECH_INSTALL%\library\
if "%CGTECH_LICENSE%" == "" set CGTECH_LICENSE=%CGTECH_PRODUCTS%\license
if "%TEMP%" == "" set TEMP=C:\TEMP
if "%TMP%" == "" set TMP=C:\TEMP
if "%CGTECH_LOCALE%" == "" set CGTECH_LOCALE=english
set CGTECH_LANGUAGE=%CGTECH_CLASSES%\%CGTECH_LOCALE%
set CGTECH_HELP=%CGTECH_INSTALL%\hhelp
set CGTECH_SAMPLES=%CGTECH_INSTALL%\samples\
set CGTECH_TRAINING=%CGTECH_INSTALL%\training\
set CGTECH_DEFAULT_UNITS=INCH
set CGTECH_RGB_TXT=%CGTECH_PRODUCTS%\vericut\rgbhues.txt
if "%CGTECH_JRE%" == "" set CGTECH_JRE=%CGTECH_PRODUCTS%\jre
set path=%CGTECH_PRODUCTS%\vericut;%CGTECH_PRODUCTS%\license;%PATH%
set waitopt=
set argstr=
if test%1==test goto cgtchkend
if %1==BATCH set waitopt=/wait
if %1==batch set waitopt=/wait
if %1==BATCHP set waitopt=/wait
if %1==batchp set waitopt=/wait
set argstr=%1
shift
:cgtgetarg
if test%1==test goto cgtchkend
if %1==BATCH set waitopt=/wait
if %1==batch set waitopt=/wait
if %1==BATCHP set waitopt=/wait
if %1==batchp set waitopt=/wait
set argstr=%argstr% %1
shift
goto cgtgetarg
:cgtchkend
if "%OS%" == "Windows_NT" set start_cmd=start "VERICUT" %waitopt%
if "%OS%" == "" set start_cmd=start %waitopt%
set UGII_VENDOR_DIR=%CGTECH_PRODUCTS%\nx\nx7.5
rem "%UGII_ROOT_DIR%\UGII.BAT" %argstr%
:end_cgtech

rem endlocal
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If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.

You should now be ready to start using the NX-to-VERICUT Interface. For complete
details on using the NX-to-VERICUT Interface, see NX-to-VERICUT Interface (NXV), in the
CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces, located in the
CGTech Help Library.

Return to “Other Configuration Tasks”
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Starting NXV when starting NX from Start > All Programs
> Siemens NX x.x > NX x.x
Follow the following steps to enable using the NX-to-VERICUT Interface (NXV) when
starting NX from Start > All Programs > Siemens NX x.x > NX x.x, where x.x is the NX
version number.
The CGTech software installation procedure places the files required by NXV in a subfolder. If you elected to install the software in the default folder "C:\Program
Files\cgtech\x.x.x" (where x.x.x is the VERICUT release number), then for VERICUT 9.0,
the NXV folder will be "C:\Program Files\cgtech\VERICUT 9.0\windows\nx" or
"C:\Program Files\cgtech\ VERICUT 9.0\windows64\nx".
Copy the files in:
C:\Program Files\cgtech\VERICUT 9.0\windows64\nx\NXx.x\application\
where x.x is the NX version number.
to:
C:\Program Files\UGS\NX x.x\UGALLIANCE\vendor\application\, where x.x is the
NX version number.
Copy the files in:
C:\Program Files\cgtech\VERICUT 9.0\windows64\nx\NXx.x\startup\
to:
C:\Program Files\UGS\NX x.x\UGALLIANCE\vendor \startup\
where x.x is the NX version number.
Edit the file:

C:\Program Files\UGS\NX x.x\UGII\ugii_env.dat
where x.x is the NX version number.
Remove the "#" from variable

#UGII_VENDOR_DIR=${UGALLIANCE_DIR}vendor
so that it now looks like

UGII_VENDOR_DIR=${UGALLIANCE_DIR}vendor
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To enable NX to find VERICUT, you also need to define two environment variables,
CGTECH_PRODUCTS and CGTECH_INSTALL.
For example;

Environment Variable Name

Variable Value

C:\Program Files\cgtech\VERICUT 9.0\

CGTECH_INSTALL

CGTECH_PRODUCTS

C:\Program Files\cgtech\VERICUT 9.0\windows64\

CGTECH_INSTALL is set to the top level folder where VERICUT is installed. In the above
table, x.x.x represents the VERICUT release number. For a typical VERICUT 9.0
installation the environment variable would be set to C:\Program Files\cgtech\VERICUT
9.0
CGTECH_PRODUCTS is set to C:\Program Files\cgtech\VERICUT 9.0\windows
\windows64.
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.
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Configuring the NX-to-VERICUT Drilling and Fastening
Interface (NX2VDAF)
This section documents supported versions of NX, and the procedure for configuring the
NX-to-VERICUT Drill and Fastener Interface (NX2VDAF). These instructions apply only
when VERICUT will be run via NX2VDAF. If VERICUT will only be run outside of NX, then
ignore this section.

NX version support
NXV can be operated on Windows computers with NX versions NX8, NX8.5 and NX9.

Configuration
Follow the general procedure below to configure NXV. Integrating NXV into your
standard NX startup may require "root" or administrator permissions - see your system
administrator for assistance.
NOTE: The following NX products, ufunc_execute (P2_ufunc_execute for NX2, product
name "UG/Open API Execute") and the grip_execute (product name "UG/Open Grip
Execute") are required for NX2VDAF.
Assuming NX is installed, install VERICUT Drilling and Fastening (includes the NX2VDAF
software) per the VERICUT Drill and Fastener installation instructions.
Windows
1. Locate the NX2VDAF batch file for your version of NX
Look in VERICUT’s 'commands' folder (C:\Program Files\cgtech\VERICUT
9.0\windows64\commands\ directory of your VERICUT installation. The batch
file sets the environment for NX2VDAF, then runs NX using
%UGII_ROOT_DIR%\UGII.BAT.
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The following optional environment variables are available for use in the
nx2vdafV.bat (where V represents the NX version, i.e. nx2vdaf8.bat,
nx2vdaf8_5.bat, nx2vdaf9.bat, etc.) file.
CGTECH_NXV_OUTPUTDIR
The environment variable CGTECH_NXV_OUTPUTDIR can be used to set the NXV
Output Directory.
For example,
set CGTECH_NXV_OUTPUTDIR=C:\CGTech\nxv\working\tmp
It may be convenient for those who want to have the same Output Directory for
all NXV projects.

CGTECH_NXV_PROJTEMPLATE
The environment variable CGTECH_NXV_PROJTEMPLATE can be used to set the
NXV Project Template.
For example,
set CGTECH_NXV_PROJTEMPLATE=C:\CGTech\nxv\working\NXV_Template.vcproject

It may be convenient for those who want to have the same Project Template for
all NXV projects.
If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

2. Create a desktop shortcut to the batch file
Create a desktop shortcut that points to the nx2vdaf batch file found in step 1.
Set the shortcut's start-in property to a folder where the user has write
permission.
You can optionally copy the batch file to a folder where you have write
permission and run it directly from there.
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NOTE: The nx2vdaf batch file will NOT work correctly from its location in the
VERICUT’s ‘commands’ folder because users usually do not have write
permissions there. You must either create a desktop shortcut with a start-in path
where you have write permissions, or copy the batch file to a directory where
you have permission to write files.
NOTE FOR NX SYSTEM ADMINISTRATORS: To integrate the NXV interface into
your normal NX startup process, copy the environment settings from
nx2vdaf.bat into your normal NX startup process. Do not copy the line that runs
NX.

Start NX with NX2VDAF.
After completing the previous steps and assuming VERICUT Drilling and Fastening is
licensed and operational, run NX using the batch file short cut. If NX does not start, DO
NOT CONTINUE - see your system administrator for assistance.
Depending on the version of NX, NX2VDAF is accessed differently. See the help on using
NXV in the Converters and CAD/CAM Interfaces section, in the CGTech Help Library, for
details.

Configuring NX2VDAF to start VERICUT with a custom Project file
If no Project Template is specified in the VDAF Interface window, NX2VDAF initializes
VERICUT Drilling and Fastening with the following project from VERICUT’s Library folder:
•

init.vdafproject (inch NX session)

•

initm.vdafproject (millimeter NX session)

The interface adds models from the current session, and then runs VERICUT Drilling and
Fastening.
You can change VERICUT’s default settings by modifying init.vdafproject (or
initm.vdafproject). We recommend you save a backup copy of these files before
modifying them. The files are located in the "library" folder in your VERICUT Drilling and
Fastening installation.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the NX-to-VERICUT Drilling and Fastening
Interface. For complete details on using the NX-to-VERICUT Drilling and Fastening
Interface, see NX-to-VERICUT Drilling and Fastening Interface (NX2VDAF), in the
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CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces, located in the
CGTech Help Library.
Return to “Other Configuration Tasks”
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Setting up NX2VDAF to work with Teamcenter
Overview
Teamcenter (formerly IMAN and UG Manager) is a Product Lifecycle Management (PLM)
application that manages NX data files. When using the NX-to-VERICUT Drilling and
Fastening Interface (NX2VDAF), it is necessary to modify the NX Teamcenter
environment in order for NX2VDAF to operate correctly.
NX2VDAF uses Teamcenter functions for reading data and writing files when running
within Teamcenter.
For example:
•

If Teamcenter is not used, NX2VDAF asks NX to write VERICUT Drilling and
Fastening model files to the path specified in the NX2VDAF interface.

•

If Teamcenter is used, NX2VDAF asks Teamcenter to ask NX to write model files.
Teamcenter then places the files in a "temporary" Teamcenter folder.

NX2VDAF detects when it is running within Teamcenter and uses Teamcenter data
management functions when requesting and writing data.
All VERICUT Drilling and Fastening files for the current session are placed by Teamcenter
in the "temporary" Teamcenter folder for the current checked-out project. At the end of
the NX session, Teamcenter prompts the user to check the files in.
VERICUT Drilling and Fastening files are considered, "meta-data" by Teamcenter. "meta
data" is data with unknown content, but the files are controlled by Teamcenter.

Implementing NX2VDAF in a Teamcenter installation
NOTE: The following example shows modifying a Teamcenter windows batch file for
NX8 on Windows, but the concept is the same for later NX versions.
The Teamcenter startup batch file (in this example, START_UGMANAGER.BAT) sets the
environment for starting NX8 with Teamcenter on Windows. The Teamcenter startup
batch file must be modified to call the modified NX2VDAF batch file (nx2vdaf8.bat,
nx2vdaf8_5.bat, nx2vdaf9.bat,etc, depending on your version of NX) from VERICUT’s
commands folder.
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1. Modify 4 lines in NX2VDAF’s startup batch file.
Add rem at the beginning of the following lines in the nx2vdafv.bat file. Where v
is the NX version number.
rem setlocal
rem set CGTECH_INSTALL=C:\Program Files\cgtech\VERICUT 9.0
rem "%UGII_ROOT_DIR%\UGII.BAT" %argstr%
rem endlocal
See the red text in the example modified nx2vdaf8.bat file below.
2. Call the NXV batch file (as modified in step 1) from the Teamcenter startup
script. The call must be inserted above the command that launches NX. Calling
the NXV batch file sets the environment for NXV and VERICUT from the
Teamcenter startup script. This edit is usually done by the Teamcenter site
administrator.
Example lines to add to a Teamcenter startup batch file that uses Windows batch
file syntax:
set CGTECH_INSTALL= C:\Program Files\cgtech\VERICUT 9.0
call "%CGTECH_INSTALL%\windows\commands\NX2"
3. The Teamcenter site administrator needs to configure Teamcenter to recognize
VERICUT files as "meta-data". An entry must be made for each extension
(.VcProject .mch, .ctl, .tls, .opti, .swp, .sor, .vct, etc?) These files will be managed
by Teamcenter.
NOTE: Two temporary files are created by NXV, but do not need to be managed
by Teamcenter. They have extension .opts and .vctemp.
Sample edited nx2vdaf8.bat file
(the four edited lines are highlighted red)
@echo off
rem setlocal
rem set CGTECH_INSTALL=c:\program files\cgtech\vericut 9.0
rem

CGTech, Copyright, All Rights Reserved
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rem CGTech environment
set CGTECH_PRODUCTS=%CGTECH_INSTALL%\windows64
call "%CGTECH_PRODUCTS%\commands\cgtenv"
rem set CGTECH_IGNORELAST=TRUE
set CGTECH_CLASSES=%CGTECH_INSTALL%\classes

if "%CGTECH_LIBRARY%" == "" set CGTECH_LIBRARY=%CGTECH_INSTALL%\library\
if "%CGTECH_LICENSE%" == "" set CGTECH_LICENSE=%CGTECH_PRODUCTS%\license

if "%TEMP%" == "" set TEMP=C:\TEMP
if "%TMP%" == "" set TMP=C:\TEMP
if "%CGTECH_LOCALE%" == "" set CGTECH_LOCALE=english
set CGTECH_LANGUAGE=%CGTECH_CLASSES%\%CGTECH_LOCALE%
set CGTECH_HELP=%CGTECH_INSTALL%\hhelp
set CGTECH_SAMPLES=%CGTECH_INSTALL%\samples\
set CGTECH_TRAINING=%CGTECH_INSTALL%\training\
set CGTECH_DEFAULT_UNITS=INCH
set CGTECH_RGB_TXT=%CGTECH_PRODUCTS%\vericut\rgbhues.txt
if "%CGTECH_JRE%" == "" set CGTECH_JRE=%CGTECH_PRODUCTS%\jre

set path=%CGTECH_PRODUCTS%\vericut;%CGTECH_PRODUCTS%\license;%PATH%
set ARG_SPLASH=-splash:"%CGTECH_CLASSES%\startup.png"
set WAITOPT=
set ARGSTR=
:cgtgetarg
if test%1==test goto cgtchkend
if /I %1==BATCH (
set WAITOPT=/wait
set ARG_SPLASH=
)
set ARGSTR=%ARGSTR% %1
shift
goto cgtgetarg
:cgtchkend
if "%OS%" == "Windows_NT" set start_cmd=start "VERICUT" %WAITOPT%
if "%OS%" == "" set start_cmd=start %WAITOPT%
if exist "%CGTECH_PRODUCTS%\nx2vdaf\nx8\%CGTECH_LOCALE%" (
set UGII_VENDOR_DIR=%CGTECH_PRODUCTS%\nx2vdaf\nx8\%CGTECH_LOCALE%
) else if exist "%CGTECH_PRODUCTS%\nx2vdaf\nx8\english" (
set UGII_VENDOR_DIR=%CGTECH_PRODUCTS%\nx2vdaf\nx8\english
) else (
set UGII_VENDOR_DIR=%CGTECH_PRODUCTS%\nx2vdaf\nx8
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)
rem "%UGII_ROOT_DIR%\UGII.BAT" %ARGSTR%
:end_cgtech
rem endlocal

If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.

You should now be ready to start using the NX-to-VERICUT Drilling and Fastening
Interface. For complete details on using the NX-to-VERICUT Drilling and Fastening
Interface, see NX-to-VERICUT Drilling and Fastening Interface (NX2VDAF), in the
CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces, located in the
CGTech Help Library.

Return to “Other Configuration Tasks”
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Starting NX2VDAF when starting NX from Start > All
Programs > Siemens NX x.x > NX x.x
Follow the following steps to enable using the NX-to-VERICUT Drilling and Fastening
Interface (NX2VDAF) when starting NX from Start > All Programs > Siemens NX x.x > NX
x.x, where x.x is the NX version number.
The CGTech software installation procedure places the NX version specific files required
by NX2VDAF in a sub-folder of "C:\Program Files\cgtech\ VERICUT
9.0\windows64\nx2vdaf".
Copy the files in:
C:\Program Files\cgtech\VERICUT 9.0\windows64\nx\NXx.x\application\
where x.x is the NX version number.
to:
C:\Program Files\UGS\NX x.x\UGALLIANCE\vendor\application\, where x.x is the
NX version number.
Copy the files in:
C:\Program Files\cgtech\VERICUT 9.0\windows64\nx2vdaf\NXx.x\startup\
to:
C:\Program Files\UGS\NX x.x\UGALLIANCE\vendor \startup\
where x.x is the NX version number.
Edit the file:

C:\Program Files\UGS\NX x.x\UGII\ugii_env.dat
where x.x is the NX version number.
Remove the "#" from variable

#UGII_VENDOR_DIR=${UGALLIANCE_DIR}vendor
so that it now looks like
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UGII_VENDOR_DIR=${UGALLIANCE_DIR}vendor
To enable NX to find VERICUT Drilling and Fastening, you also need to define two
environment variables, CGTECH_PRODUCTS and CGTECH_INSTALL.
For example:
Environment Variable Name

Variable Value

CGTECH_INSTALL

C:\Program Files\cgtech\VERICUT 9.0

CGTECH_PRODUCTS

C:\Program Files\cgtech\VERICUT 9.0\windows64

CGTECH_INSTALL is set to the C:\Program Files\cgtech\VERICUT 9.0
CGTECH_PRODUCTS is set to C:\Program Files\cgtech\VERICUT 9.0\windows64.
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.
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Configuring the Pro/E-to-VERICUT Interface (PROEV)
NOTE: The Pro/E-to-VERICUT Interface (PROEV) requires Pro/E Wildfire 5.0, Pro/E Creo
Elements Pro 5.0, Creo Parametric 1.0, Pro/E Creo / Creo Parametric 2.0 or
Pro/E Creo / Creo Parametric 3.0

Installation
The Pro/E-to-VERICUT Interface is distributed as twenty files located in the C:\Program
Files\CGTech\VERICUT x.x.x\windows64\proev\WFyy\ directory of your VERICUT
installation. The x.x.x represents the VERICUT release number, for example 9.0. The yy
represents the PTC version number, for example 50 for CREO Elements/Pro 5.0.
The following files are located in the \proev\WFyy\ directory of your VERICUT
installation.
cgtproev.dll (application dll)
ProevChinese.local
(localization file)
ProevEnglish.local
(localization file)
ProevFrench.local
(localization file)
ProevGerman.local
(localization file)
ProevItalian.local
(localization file)
ProevJapanese.local
(localization file)
Proev Portuguese.local (localization file)
protk.dat
(registry file)
The following file is located in the \proev\WFyy\text\ directory of your VERICUT
installation.
proev.txt

(resource file)

The following files are located in the \proev\WFyy\text\resource\ directory of your
VERICUT installation.
cl_cancel.bif
proev_db_design_page.res
proev_db_file_page.res
proev_db_fixture_page.res
proev_db_main_page.res
proev_db_ops_page.res
proev_db_options_page.res
proev_db_process_page.res
proev_db_settings_page.res
proev_db_stock_page.res
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Vericut16.gif
Vericut32.gif
The following files are located in the \proev\WFyy\text\ribbon\ directory of your
VERICUT installation.
Thumbs.db
proev.rbn
1. Copy the protk.dat file to the “start in” directory per the properties of the
shortcut.
At startup, Pro/ENGINEER will look for the registry file, protk.dat, to get location
information about the other files used by the Pro/E-to-VERICUT Interface.
Pro/Engineer will look for the protk.dat file first in the “start in” directory, then it
will look in “<Pro/ENGINEER>/<MACHINE>/text” and finally it will look in
“<Pro/ENGINEER>/text.”
The protk.dat file contains the following information:
name cgtproev
startup dll
exec_file <full path, including the file name, where the cgtproev.dll is located>
text_dir <full directory path to the directory, where the proev.txt file is located>
revision Wildfire
end
2. Edit the protk.dat file to point to the locations of the cgtproev.dll and the proev.txt
file.
The protk.dat file specifies the location of the cgtproev.dll file and the proev.txt file.
Edit exec_file so that it points to the \proev\WFyy\cgtproev.dll of your VERICUT
installation. Edit text_dir so that it points to the \proev\WFyy\text directory of your
VERICUT installation. The protk.dat file should look similar to the following after
editing:
name cgtproev
startup dll
exec_file C:\Program Files\cgtech\x.x.x\windows\proev\WFyy\cgtproev.dll
text_dir C:\Program Files\cgtech\x.x.x\windows\proev\WFyy\text
revision Wildfire
end
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where x.x.x is the VERICUT version number and yy is the Pro/E Wildfire version
number. \windows\ could be \windows64\ depending on whether you are running a
32 bit or 64 bit computer.
The proev.txt file contains the resource text for the VERICUT option which shows up
in Pro/ENGINEER under the "Applications" menu. The VERICUT option is the entry
point for launching the Pro/E-to-VERICUT Interface.

The proev.txt file contains the following information:
PROEV_VERICUT_BUTTON_LABEL
VERICUT...
PROEV_VERICUT_BUTTON_HELP
Invoke the VERICUT Interface
3. Set the following environment variables.
PROEV is dependent on the following environment variables:
•
•
•
•
•
•
•

PROEV_LANGUAGE
CGTECH_PRODUCTS
LSHOST
CGTECH_LIBRARY
(used only for Pro/E versions prior to Pro/E Creo / Creo Parametric 3.0
CGTECH_SINGLE_PLATFORM
HOMEDRIVE
HOMEPATH

To enable Pro/ENGINEER to find the PROEV language file and other necessary
VERICUT files, you also need to define four environment variables,
PROEV_LANGUAGE, CGTECH_PRODUCTS, LSHOST and CGTECH_LIBRARY.
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If you are using VERICUT single Platform then an additional environment variable
needs to be defined for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

For example:
Environment Variable
Name

PROEV_LANGUAGE

Variable Value

C:\Program Files\CGTech\VERICUT x.x\windows64\proev\WFyy\
Proev[language].local

CGTECH_PRODUCTS

C:\Program Files\CGTech\VERICUT x.x\windows64

LSHOST

server_name

CGTECH_LIBRARY

C:\Program Files\CGTech\VERICUT x.x\library
(used only for Pro/E versions prior to Pro/E Creo / Creo Parametric 3.0

In the above examples, x.x is the VERICUT release number and yy is the WildFire
version number
PROEV_LANGUAGE is used to specify the path/filename of the PROEV language file
(Proev[language].local) that you want to use.
CGTECH_PRODUCTS is used to specify the folder, for the specific operating system,
of the VERICUT installation: "windows64". In the above table, x.x.x represents the
VERICUT release number. For a typical VERICUT 9.0 installation this variable is set to
C:\Program Files\CGTech\VERICUT 9.0\windows64.
LSHOST is set to the name of the license server computer.
CGTECH_LIBRARY is used to specify the folder, where VERICUT library machine and
control files are located. In the above table, x.x.x represents the VERICUT release
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number. For a typical VERICUT 9.0 installation this variable is set to C:\Program
Files\CGTech\VERICUT 9.0\library. This enables PROEV to find machine and control
files referenced in the template file. This environment variable is only used for Pro/E
versions prior to Pro/E Creo / Creo Parametric 3.0.
Use the Microsoft Windows Control Panel > System Properties: Advanced tab,
Environment Variables feature to define these environment variables. See Microsoft
Windows Help for more information.
4. Create a shortcut to start Pro/E.
For Pro/E Wildfire 5.0 and Pro/E Creo Elements Pro 5.0:
Create a shortcut for “C:\Program Files\PTC\Creo
Elements\Pro5.0\bin\proe.exe” and change the shortcut property ‘Start In:’ to
“C:\PROEV”.
Now you can run PROEV by launching Pro/E with this shortcut.
For Pro/E Creo Parametric 1.0 / Creo Parametric 2.0 / Creo Parametric 3.0 :
Create a shortcut for “C:\Program Files\PTC\Creo
X.0\Parametric\bin\parametric.exe”, where X.0 is the Creo Parametric version
number, and change the shortcut property ‘Start In:’ to “C:\PROEV”.
Now you can run PROEV by launching Pro/E with this shortcut.
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Accessing the Pro/E-to-VERICUT Interface
Pro/E Wildfire 5.0, Pro/E Creo Elements Pro 5.0
To start the Pro/E-to-VERICUT Interface from within Pro/ENGINEER, click on
Applications in the Pro/ENGINEERING main menu, then select VERICUT from the pulldown list as shown in the picture below. Holding the cursor over the VERICUT option will
display the tip shown in the yellow text box below.

Creo Parametric 1.0 / Creo Parametric 2.0 / Creo Parametric 3.0
To start the Pro/E-to-VERICUT Interface from within Pro/ENGINEER click on Tools tab >
Tools > Applications > VERICUT in the Pro/ENGINEERING main menu, as shown in the
picture below. Holding the cursor over the VERICUT option will display the tip shown in
the text box below.
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If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
You should now be ready to start using the Pro/E-to-VERICUT Interface. For complete
details on using the Pro/E-to-VERICUT Interface, see Pro/E-to-VERICUT Interface
(PROEV), in the CAD/CAM Interfaces section of Converters and CAD/CAM Interfaces,
located in the CGTech Help Library.
Return to “Other Configuration Tasks”
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Configuring the SolidWorks-VERICUT Interface
Installation
This section describes how to install the SolidWorks-to-VERICUT Interface. You are
required to have administrator privileges for the computer on which you are installing
the SolidWorks-to-VERICUT Interface.
You can put the interface installation files anywhere on the computer as long as, all the
files are in the same folder. For consistency, it is preferable that you create new folder
named VericutAddin, in the SolidWorks system installation folder and store all of the
SolidWorks-to-VERICUT Interface installation files there.
The SolidWorks-to-VERICUT Interface installation files are located in the solidworks
folder of your VERICUT installation. For a typical VERICUT installation, the files would be
located in C:\Program Files\CGTech\VERICUT 9.0\windows64\solidworks.
The list of installation files is shown below:
•
•
•
•
•
•

VericutAddin.dll
register-VericutAddin_dll.bat
unregister-VericutAddin_dll.bat
register-Vericut-addin-to-SW-64.reg
VericutAddin.bmp
Vericut.ico

Once, all of the files are copied to the VericutAddin folder described above, you need to
register the files with Windows and also with ‘SolidWorks’.
You can register the VericutAddin.dll with SolidWorks by double left clicking on provided
‘register-Vericut-addin-to-SW-64.reg’ file. The SolidWorks-to-VERICUT Interface is only
designed to support 64 Bit Solidworks.
You also need to register the VericutAddin.dll location with Windows by double left
clicking the provided register batch file, register-VericutAddin_dll.bat.
NOTE: The VericutAddin.dll file must be located in the same folder as the registerVericutAddin_dll.bat file as described above.
Please keep in mind, for both of these above mentioned registering processes; you need
to have administrative privileges on the computer. If everything goes successfully, you
should be able to see the Vericut Addin in the addin-manager dialog of SolidWorks.
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Environment Variables
The following environment variables need to be defined for the SolidWorks-to-VERICUT
Interface to work.
Environment Variable
Name

Description

LSHOST

Name of the License Server.

LSFORCEHOST

Alternate name for the License Server.

APPDATA

Full-path to the ‘Application Data’ directory. User preferences
for the interface are being stored here in exclusive subdirectory for the interface. It is recommendable to continue
with system define value of this variable.

Return to “Other Configuration Tasks”
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Configuring the SURFCAM-to-VERICUT Interface
Start by copying the interface files from your VERICUT installation to the public user
folder. You’ll need to copy all the files that are in the surfcam folder.
Default VERICUT installation location:
C:\Program Files\CGTech\VERICUT 9.0\windows64\surfcam

Next, store the interface files at:
“C:\Users\Public\SURFCAM\SURFCAM6\UserApps\VERICUT” location, on your machine.
NOTE: You will have to create ‘UserApps’ and ‘VERICUT’ directories manually.
Change ‘SURFCAM.INI’ file in order for Surfcam to get the location of addin dll.
SURFCAM.INI file can be found at “C:\Users\Public\SURFCAM\SURFCAM6\Config”
location. Please, right click and open the file in notepad. You have to look for ‘Specify
Plug-Ins option’ section. And make the following changes into it.
Before making any changes, please back up the file by saving with different name.
;__________________________ Specify Plug-Ins option ___________________________
UserApplications=1
UserApp1=C:\Users\Public\SURFCAM\SURFCAM6\UserApps\VERICUT\Vericut_Interface.dll,"VE
RICUT Interface"
Save the file.
Define the required environment variables to locate the VERICUT installation directory and set
the surfcam language.
CGTECH_INSTALL = C:\cgtech82x
CGTECH_PRODUCTS = C:\cgtech82x\windows64
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LSHOST = localhost

If you are using VERICUT single Platform then an additional variable needs to be defined
for the interface.
•

CGTECH_SINGLE_PLATFORM=YES

4. To launch the interface select Add Ins > VERICUT Interface

VERICUT Settings
In order to locate ‘Vericut’ installation directory, interface needs to have value for
‘Vericut’ product directory and ‘Vericut’ install directory. Both values can be defined as
environment variable ‘CGTECH_PRODUCTS’ and ‘CGTECH_INSTALL’, respectively.
However, defining value explicitly to ‘CGTECH_INSTALL’ variable is optional. It can be
derived from ‘CGTECH_PRODUCTS’ variable value.
If any of the variable remains undefined at the end, execution returns back from there
and interface dialog does not open up.
Interface Language
Environment variable ‘CGTECH_SURFCAM_LANGUAGE’ is used to define location path of
the local file, and environment variable ‘CGTECH_SURFCAM_LOCALE’ is used to define
name of the language, which user prefers to display on the interface. At least, one of
these two variables needs to be defined to have desired language on the interface.
When the interface in launched, there is a check for environment variable
‘CGTECH_SURFCAM_LANGUAGE’. If it is defined, interface loads the ‘SurfcamRes.local’
file found at that location. If ‘CGTECH_SURFCAM_LANGUAGE’ variable is NOT defined,
execution moves on to check the ‘CGTECH_SURFCAM_LOCALE’ environment variable to
get the language name.
In this case, interface tries to look for ‘SurfcamRes.local’ file at the location where
‘Vericut_Interface.dll’ is saved, under the directory, named same as specified language.
If, ‘CGTECH_SURFCAM_LOCALE’ environment variable is also not found, the default
language is taken as ‘English’. Also, if local file for specified language is not found,
‘English’ would be considered as application language.
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Environment variables (shown with typical settings)
Environment Variable Name
CGTECH_INSTALL

Variable Value
C:\Program Files\cgtech\VERICUT x.x.x
C:\Program Files\cgtech\VERICUT x.x.x\windows

CGTECH_PRODUCTS

or
C:\Program Files\cgtech\VERICUT x.x.x\windows64

LSHOST

server_name

CGTECH_SURFCAM_LANGUAGE

C:\Users\Public\SURFCAM\SURFCAM6\UserApps\VERICUT\english

CGTECH_SURFCAM_LOCALE

English

Return to “Other Configuration Tasks”
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Configuring the Teamcenter Interface (TCI)
This section documents the necessary steps make to the Teamcenter Interface to work
in your environment. There are several configuration steps that need to be completed
and several software versions that must be met. These instructions apply only when
connecting VERICUT with Teamcenter.
Software Prerequisites
The Teamcenter Interface has several software version requirements.
• Siemens software prerequisites:
o NX version 10 or higher
o Teamcenter version 10 or higher
o MRL (Manufacturing Resource Library) version3.1.5 or higher, if MRL is
being used
o SFC (ShopFloor Connect) version 2017.4 or higher
• VERICUT software prerequisites:
o VERICUT 9.0 or higher
o NXV Interface
o Teamcenter Interface
License Prerequisites
The Teamcenter Interface requires an additional software license from Siemens to work:
• (TCM55072) Siemens 3rd party CAM access to Teamcenter MRL license
Configuration
•

SFC (ShopFloor Connection) Configuration
o Contact technical support for help in configuring SFC to work with the
Teamcenter Integration
o This process must be done in order for the interface to work properly.
• Local Computer Configuration
o Ensure the correct environment variables are set for the current version
of NX that is being used.
Variable
Value
UGII_BASE_DIR
C:\Program Files\Siemens\NX 10.0\
UGII_ROOT_DIRC

:\Program Files\Siemens\NX 10.0\UGII

o These variables should be set correctly from the installation of NX
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•

VERICUT Configuration
o Ensure the following variables are set correctly in the vericut.bat and
toolman.bat files

Variable
CGTECH_TC_WORKPLACE
CGTECH_TC_NXP_TYPE
CGTECH_TC_TOOL_TYPE

Value
Used to set Teamcenter workplace.
Expected value - vericut
Defines Teamcenter item type for NX Projects
Expected value - MENCMachining
Defines Teamcenter item type for NX Tools
Expected value - MENCTool

NOTE: A workplace named ‘vericut’ should be defined when SFC is configured. If a

different workplace name is used during the configuration that name should be used for
this variable.If different item types are used in Teamcenter for NX CAM projects and
cutting tool assemblies, those item names need to be entered as values for the above
variables.
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Configuring the VERICUT TDM Systems Interface
VERICUT connects to the TDM Systems tool management database using a Dynamic Link
Library (DLL) supplied by TDM Systems. It is mandatory to use the DLL supplied with
your specific TDM installation since the DLL is both specific to the TDM version and to
the Oracle database version.
Copy the TDMAPI.dll from your TDM installation into the …\windows\vericut folder of
your VERICUT installation (for example, C:\Program Files\cgtech\x.x.x\windows\vericut,
where x.x.x is the VERICUT release number, for example 9.0). An optional VERICUT
license from CGTech is required in order for VERICUT to access tool data that resides in
the TDM Oracle database. Once the license and DLL are in place VERICUT’s TDM Systems
Interface can then be invoked from the Tool Manager > File menu.
Creation of VERICUT tool information in the TDM database requires custom
configuration services from TDM Systems, and an optional license from TDM Systems to
enable creation of tool data for VERICUT.
The TDM configuration and installation instructions are part of the TDM install
documents provided by TDM Systems.

Return to “Other Configuration Tasks”
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Configuring the WinTool Interface
VERICUT has the ability to easily use 3D tooling generated from the WinTool tool data
management system. WinTool is an independent tool database management system.
WinTool generates a .tls file for use in VERICUT’s Tool Manager. This .tls file can be
generated independently from VERICUT or from launching the WT-Tool Export
executable (for example "C:\Program Files (x86)\WinTool\WT-VERICUT-Interface\WTToolExport.exe") via the WinTool icon from Tool Manager’s Import ribbon.
The WinTool icon in VERICUT’s Tool Manager is inactive, by default. Installation of the
WinTool tool data management software is a requirement in order to use the WinTool
icon within Tool Manager. The icon will automatically become active if WinTool
software is installed and one of the following criteria are met. These criteria are
checked in the following order:
•
•
•

‘CGTECH_WINTOOL’ environment variable (should be defined during WinTool
installation)
.exe file path is set in VERICUT Tool Manager’s Preference dialog under CAD Tool
Import Executables section
Windows registry (should be defined during WinTool installation)

The WinTool configuration and installation instructions are part of the WinTool install
documents by WinTool AG. For further details on the WinTool WT-ToolExport interface
see the WT-VERICUT-Interface-Manual-E.pdf (for example: C:\Program Files
(x86)\WinTool\WT-VERICUT-Interface\Docs\WT-VERICUT-Interface-Manual-E.pdf) or
contact WinTool.

160

Installing CGTech Products

Installing the Model Interface Modules
The Model Interface modules (CATIA V4 Model Interface, CATIA V5 Model Interface,
STEP Model Interface, and ACIS Model Interface) enable VERICUT to both read and,
when combined with Model Export, write the designated model file formats. These
modules do not require a CAD/CAM system be available for VERICUT to read or write
any of the formats. The modules are available for both Windows 32 bit, and Windows
64 bit platforms. Each module is licensed separately.
Model interfaces are installed from a separate installer executable (not part of the
VERICUT installer). The Model Interface installer is available for download from
CGTech’s website, and it is also distributed on the VERICUT 9.0 DVD. To download the
model interface installer appropriate for your current VERICUT installation:
1. Click on the appropriate link below to start the download of the model interface
installer for your VERICUT version:
http://www.cgtech.com/products/latest-release/vericut-download/modelinterfaces
2. Unzip the model_interfaces_vx.x.x.zip file (where x.x.x is the VERICUT release
number) to extract the installer executable to a folder.
To start the installation:
Double-click on installer executable (either the downloaded installer executable from
step 2 above, or the installer executable on the VERICUT 9.0 DVD) to display the Installer
window. Follow the instructions in the Installer to complete the installation process.
Make sure to select the correct VERICUT installation folder, for example C:\Program
Files\cgtech\VERICUT 9.0
NOTES:
1. You may need to have the latest Microsoft Windows updates installed (as of
August 14, 2009) for the CAD Model Interfaces to work correctly.
2. If you get the following error message "Error loading ACIS libraries!", or no error
message at all try installing the Microsoft redistributable C++ run-time libraries.
See the Install Microsoft redistributable C++ Run-Time Libraries topic above for
additional information. You must have Administrator privileges to do the install.
VERICUT's CAD Model Interface modules should now be available if you are licensed to
use them.
If errors occur, visit the VERICUT Users' Forum or contact CGTech technical support via
our website, just click on the support link.
Return to “Other Configuration Tasks”
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